php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #62472 APC conflicts with PHP's Session Upload Progress
Submitted: 2012-07-03 15:51 UTC Modified: 2012-07-03 15:57 UTC
Votes:1
Avg. Score:4.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:0 (0.0%)
From: danny at tibibi dot com Assigned:
Status: Wont fix Package: APC (PECL)
PHP Version: 5.4.4 OS: Windows 7/ Windows Server 2008
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: danny at tibibi dot com
New email:
PHP Version: OS:

 

 [2012-07-03 15:51 UTC] danny at tibibi dot com
Description:
------------
If you have APC rfc1867 enabled, then when trying to use php's built in Session Upload Progress does not work. When submitted a field with PHP_SESSION_UPLOAD_PROGRESS before the file, the _SESSION variable never contains file upload progress information, unless APC rfc1867 is disabled.

APC rfc1867 does however always work when enabled.

It would be nice to be able to have both enabled, and use whichever one that we want at any given time.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-07-03 15:57 UTC] rasmus@php.net
-Status: Open +Status: Wont fix
 [2012-07-03 15:57 UTC] rasmus@php.net
Unfortunately having both active isn't possible due to the way the hook works. 
You have to pick one.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Jun 23 02:01:23 2021 UTC