php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #62447 FPM, libevent, Windows support
Submitted: 2012-06-29 08:03 UTC Modified: 2012-06-29 08:19 UTC
From: dave at yougeezer dot co dot uk Assigned:
Status: Wont fix Package: FPM related
PHP Version: 5.4.4 OS: Windows
Private report: No CVE-ID:
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please — but make sure to vote on the bug!
Your email address:
MUST BE VALID
Solve the problem:
13 + 25 = ?
Subscribe to this entry?

 
 [2012-06-29 08:03 UTC] dave at yougeezer dot co dot uk
Description:
------------
From what I understand, FPM isn't currently available for the Windows port of 
PHP due to it's dependency on libevent.  I'm logging this feature request as 
having FPM available on Windows would be a great boost, especially with the 
recent release of Apache 2.4, containing a new mod_proxy_fcgi module for its 
use.

If libevent doesn't provide enough cross-platform support to be suitable for the 
task, perhaps other libraries could be considered to power FPM.  For example, 
Microsoft have worked with nodejs to help produce "libuv" which they call a 
"BSD-licensed, minimal, high-performance, cross-platform networking library".

https://github.com/joyent/libuv/

It appears to put a lot of effort into Windows networking and then taking 
advantage of the libev and libeio libraries for supporting other operating 
systems.

Some developers have already started trying to make use of libuv in PHP...

http://chobie.net/article/2012/06/02/235433
https://github.com/bnoordhuis/phode

Test script:
---------------
Unable to test, no FPM support exists for Windows.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-06-29 08:19 UTC] pajoye@php.net
-Status: Open +Status: Wont fix
 [2012-06-29 08:19 UTC] pajoye@php.net
it is not due to libevent, libevent (or similar libs, or using native APIs) are 
available on Windows.

The problem is the core design of FPM, which is based on fork(), which is not 
available and can't be emulated in a good way on windows.
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Tue Aug 29 15:01:52 2017 UTC