php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #62423 problem compiling with memtrack
Submitted: 2012-06-26 15:28 UTC Modified: 2012-12-14 09:02 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: raaz14363 at yahoo dot in Assigned: tony2001 (profile)
Status: Duplicate Package: memtrack (PECL)
PHP Version: 5.4.4 OS: windows xp
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: raaz14363 at yahoo dot in
New email:
PHP Version: OS:

 

 [2012-06-26 15:28 UTC] raaz14363 at yahoo dot in
Description:
------------
C:\php-sdk\php54dev\vc9\x86\php-5.4.4>nmake

Microsoft (R) Program Maintenance Utility Version 9.00.30729.01
Copyright (C) Microsoft Corporation.  All rights reserved.

memtrack.c
ext\memtrack\memtrack.c(75) : warning C4090: '=' : different 'const' qualifiers
ext\memtrack\memtrack.c(77) : warning C4090: '=' : different 'const' qualifiers
ext\memtrack\memtrack.c(82) : warning C4090: '=' : different 'const' qualifiers
ext\memtrack\memtrack.c(84) : warning C4090: '=' : different 'const' qualifiers
ext\memtrack\memtrack.c(88) : warning C4090: '=' : different 'const' qualifiers
ext\memtrack\memtrack.c(90) : warning C4090: '=' : different 'const' qualifiers
ext\memtrack\memtrack.c(112) : error C2039: 'op_type' : is not a member of '_zno
de_op'
        c:\php-sdk\php54dev\vc9\x86\php-5.4.4\zend\zend_compile.h(74) : see decl
aration of '_znode_op'
ext\memtrack\memtrack.c(113) : error C2039: 'u' : is not a member of '_znode_op'

        c:\php-sdk\php54dev\vc9\x86\php-5.4.4\zend\zend_compile.h(74) : see decl
aration of '_znode_op'
ext\memtrack\memtrack.c(339) : warning C4018: '>=' : signed/unsigned mismatch
ext\memtrack\memtrack.c(341) : warning C4090: 'initializing' : different 'const'
 qualifiers
ext\memtrack\memtrack.c(351) : warning C4018: '>=' : signed/unsigned mismatch
ext\memtrack\memtrack.c(380) : warning C4018: '>=' : signed/unsigned mismatch
ext\memtrack\memtrack.c(383) : warning C4090: 'initializing' : different 'const'
 qualifiers
ext\memtrack\memtrack.c(391) : warning C4018: '>=' : signed/unsigned mismatch
NMAKE : fatal error U1077: '"C:\Program Files\Microsoft Visual Studio 9.0\VC\Bin
\cl.exe"' : return code '0x2'
Stop.

same is happening when trying to compile with apc,bcompiler,memcache.

configure option
C:\php-sdk\php54dev\vc9\x86\php-5.4.4>configure --disable-all --enable-cli  --en
able-cli-win32 --enable-memtrack=shared


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-06-27 02:08 UTC] aharvey@php.net
-Package: Compile Failure +Package: memtrack
 [2012-07-29 16:57 UTC] felipe@php.net
-Status: Open +Status: Assigned -Assigned To: +Assigned To: tony2001
 [2012-12-14 09:02 UTC] tony2001@php.net
-Status: Assigned +Status: Duplicate
 [2012-12-14 09:02 UTC] tony2001@php.net
Duplicate of bug #62091
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Dec 06 08:03:34 2021 UTC