php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #62371 APC incorrect buid
Submitted: 2012-06-20 09:58 UTC Modified: 2012-06-20 10:02 UTC
From: cheshirksy dot code at gmail dot com Assigned:
Status: Not a bug Package: APC (PECL)
PHP Version: 5.4.4 OS: Linux 3.0.0-17-generic-pae
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: cheshirksy dot code at gmail dot com
New email:
PHP Version: OS:

 

 [2012-06-20 09:58 UTC] cheshirksy dot code at gmail dot com
Description:
------------
APC configure script make incorrect Makefile. 
Build php-5.4.4 with prefix /opt/php-5.4.4
Build APC-3.1.10:
cd /usr/APC-3.1.10
/opt/php-5.4.4/bin/phpize
./configure ( OR ./configure --prefix=/opt/php-5.4.4)
make 
make install
BUT:
Installing shared extensions:     /usr/lib/php5/20090626+lfs/
Installing header files:          /usr/include/php5/
APC installed in /usr (preffix for default system php 5.3.6).
This is wrong. APC must be installed in /opt/php-5.4.4


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-06-20 10:02 UTC] gopalv@php.net
APC picks up php location from the php-config script

./configure --with-php-config=<php-dir>/bin/php-config

should fix that (remember make distclean)
 [2012-06-20 10:02 UTC] gopalv@php.net
-Status: Open +Status: Not a bug
 [2012-06-20 12:32 UTC] cheshirsky dot code at gmail dot com
it solved the problem. Thank you.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Aug 03 18:01:24 2021 UTC