php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #62316 Add --enable-filter flag
Submitted: 2012-06-13 18:15 UTC Modified: 2012-06-18 23:04 UTC
From: digitalprecision at gmail dot com Assigned:
Status: Not a bug Package: Filter related
PHP Version: 5.3.13 OS: CentOS release 6.2 (Final)
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: digitalprecision at gmail dot com
New email:
PHP Version: OS:

 

 [2012-06-13 18:15 UTC] digitalprecision at gmail dot com
Description:
------------
According to filter installation page: "The filter extension is enabled by 
default as of PHP 5.2.0". The problem I am having is that my configure command 
passes the --disable-all parameter so I can control exactly which packages are 
available in a PHP install. So if I pass --disable-all, and the filter extension 
is enabled by default, and there is no --enable-filter flag, then I am unable to 
install the filter package.

Output of configure --help:

root@service1 /usr/local/src/php-5.3.13 # -> ./configure --help | ack -i filter
  --with-apxs2filter[=FILE]   
                          EXPERIMENTAL: Build shared Apache 2.0 Filter module. 
FILE is the optional
  --disable-filter        Disable input filter support
  --with-pcre-dir           FILTER: pcre install prefix

Solution: To add an --enable-filter flag.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-06-14 16:50 UTC] digitalprecision at gmail dot com
Kindly disregard. According to ./configure --help: --enable-FEATURE[=ARG]  include 
FEATURE [ARG=yes], which means that I can pass --enable-filter, even though it's 
not explicitly available via the --help output.
 [2012-06-18 23:04 UTC] johannes@php.net
For any --disale-foo flag in the help there's also the --enable-foo flag. Samegoes for --without-foo vs. --with-foo. That's an autoconf "feature".
 [2012-06-18 23:04 UTC] johannes@php.net
-Status: Open +Status: Not a bug
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Nov 29 14:04:16 2022 UTC