php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #62311 gdImageGifAnimBegin etc. are missing
Submitted: 2012-06-13 08:36 UTC Modified: 2015-07-12 21:32 UTC
From: carsten_sttgt at gmx dot de Assigned:
Status: Duplicate Package: GD related
PHP Version: 5.4.3 OS: Windows 7
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: carsten_sttgt at gmx dot de
New email:
PHP Version: OS:

 

 [2012-06-13 08:36 UTC] carsten_sttgt at gmx dot de
Description:
------------
Hello,

If I look through the libgd source (2.0.34RC1 or head) [1] "gh.h" I can find:

gdImageGifAnimBegin
gdImageGifAnimAdd
gdImageGifAnimEnd
gdImageGifAnimBeginCtx
gdImageGifAnimAddCtx
gdImageGifAnimEndCtx
gdImageGifAnimBeginPtr
gdImageGifAnimAddPtr
gdImageGifAnimEndPtr

But these functions are completely missing in the bundled libgd 2.0.35 from PHP and thus are not avaliable.

Regards,
Carsten


[1] https://bitbucket.org/pierrejoye/gd-libgd/src/72a0bd3e3d73/src/gd.h



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-02-18 13:16 UTC] kalle@php.net
These functions should be available once Pierre merges the latest libgd sources into PHP, however their PHP binding could need some help implementing unless Pierre got something laying around from when it was implemented.
 [2015-07-12 21:32 UTC] cmb@php.net
-Status: Open +Status: Duplicate
 [2015-07-12 21:32 UTC] cmb@php.net
Duplicate of request #32803.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Jan 24 10:01:24 2020 UTC