php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #62301 --with-config-file-path conflicts with --with-ldap
Submitted: 2012-06-12 15:43 UTC Modified: 2015-06-17 14:30 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:1 of 2 (50.0%)
Same Version:1 (100.0%)
Same OS:0 (0.0%)
From: gmills at library dot berkeley dot edu Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 5.3.13 OS: Solaris 10
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: gmills at library dot berkeley dot edu
New email:
PHP Version: OS:

 

 [2012-06-12 15:43 UTC] gmills at library dot berkeley dot edu
Description:
------------
I am installing PHP for a group that creates and manages a number of different 
web apps, so I need a number of extensions. I discovered that although I was 
specifying the LDAP extension, it was not making it into the final PHP, as 
demonstrated by phpinfo(). I went through the process of stripping down to just 
--with-ldap and building up, and discovered that: when I specified --with-
config-file-path, the ldap module did not make it into PHP. There were no error 
messages.
Here is my config command line (edited for readability):

./configure
--prefix=/opt/csw/php5313
--disable-all
--with-pic
--disable-static
--with-ldap=shared,/opt/csw
--enable-dom
--with-zlib=/opt/csw
--enable-embedded-mysqli
--with-mysql=mysqlnd
--with-mysqli=mysqlnd
--enable-session
--with-openssl=/opt/ssl-1.0.0g
--with-openssl-dir=/opt/ssl-1.0.0g
--with-readline=shared,/opt/csw
--with-mm=/opt/extra
--enable-magic-quotes
--enable-sockets
--enable-shmop
--enable-sysvmsg
--enable-sysvsem
--enable-sysvshm
--enable-xml
--enable-libxml
--with-libxml-dir=/opt/extra
--enable-xmlreader
--enable-mbstring
--enable-mbregex
--with-iconv-dir=/opt/csw
--with-xsl=shared,/opt/csw
--with-mcrypt=shared,/opt/csw
--with-mhash=shared,/opt/csw
--enable-json
--enable-filter=shared
--enable-zip
--with-pcre-regex
--with-jpeg-dir=/opt/csw
--with-png-dir=/opt/csw
--with-gd=shared,/opt/csw
--enable-gd-native-ttf
--enable-gd-jis-conv
--enable-exif
--with-gettext=shared,/opt/csw
--with-gmp=shared,/opt/csw
--with-pear
--with-apxs2=/opt/httpd-2.2.22/bin/apxs


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-10-14 10:24 UTC] abhishek dot dujari at gmail dot com
Hi, 
I dont think we get error messages when configure faparemeters fail, they just go 
to default. Could you paste the configure output?
thanks
 [2015-06-17 14:30 UTC] mcmic@php.net
-Status: Open +Status: Not a bug
 [2015-06-17 14:30 UTC] mcmic@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately you are not using a current version of PHP -- 
the problem might already be fixed. Please download a new
PHP version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue May 17 05:05:45 2022 UTC