php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #62277 xdiff uses deprecated function_entry struct
Submitted: 2012-06-09 13:52 UTC Modified: 2012-06-12 00:24 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: Keisial at gmail dot com Assigned:
Status: Not a bug Package: xdiff (PECL)
PHP Version: 5.4.3 OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: Keisial at gmail dot com
New email:
PHP Version: OS:

 

 [2012-06-09 13:52 UTC] Keisial at gmail dot com
Description:
------------
xdiff-1.5.1 doesn't build in PHP 5.4, as it's still using the function_entry struct name, which used to be an alias defined on main/php3_compat.h, which got removed from master on 26b08f9857e79b3281d580846e8eb9c27b24af32.


The stable version (1.4.1) has the same problem, plus a static to be removed on line 38, but it's simpler to bump 1.5 branch to beta to stable.


Patches

xdiff-1.5.1.patch (last revision 2012-06-09 17:32 UTC by keisial at gmail dot com)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-06-11 01:10 UTC] felipe@php.net
It's already fixed in trunk, just needs a release.
 [2012-06-11 01:10 UTC] felipe@php.net
-Status: Open +Status: Not a bug
 [2012-06-12 00:24 UTC] felipe@php.net
A new version has been released: http://pecl.php.net/package/xdiff/1.5.2
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Nov 19 03:01:36 2019 UTC