php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #62221 Cannot use PATH_INFO pattern when compiled with apxs2filter
Submitted: 2012-06-04 04:11 UTC Modified: 2012-06-04 15:06 UTC
From: koalay at gmail dot com Assigned:
Status: Not a bug Package: Apache2 related
PHP Version: 5.4.3 OS: Fedora 15
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: koalay at gmail dot com
New email:
PHP Version: OS:

 

 [2012-06-04 04:11 UTC] koalay at gmail dot com
Description:
------------
When using PHP, compiled with the option "--apxs2filter" against Apache 2.4.2, Apache would not process any URLs like "foo.php/bar".

When compiled with "--apxs2", the URL "foo.php/bar" would be passed to "foo.php" and the $_SERVER['PATH_INFO'] would be come '/bar'.

Test script:
---------------
<?php

var_dump($_SERVER['PATH_INFO']);

?>

Expected result:
----------------
string(5) "/blog" 

Actual result:
--------------
Not Found

The requested URL /foo.php/bar was not found on this server.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-06-04 07:56 UTC] laruence@php.net
did you set AcceptPathinfo on ? 
http://httpd.apache.org/docs/2.0/en/mod/core.html#acceptpathinfo
 [2012-06-04 07:56 UTC] laruence@php.net
-Status: Open +Status: Feedback
 [2012-06-04 09:09 UTC] koalay at gmail dot com
-Status: Feedback +Status: Open
 [2012-06-04 09:09 UTC] koalay at gmail dot com
Oh, I didn't know that before. It works now with "AcceptPathInfo On". Thanks a lot. Please mention this in the documentation so others would not running in to this issue.

Thanks a lot!
 [2012-06-04 09:34 UTC] ondrej@php.net
-Type: Bug +Type: Documentation Problem
 [2012-06-04 15:06 UTC] laruence@php.net
-Status: Open +Status: Not a bug
 [2012-06-04 15:06 UTC] laruence@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sat Feb 24 02:01:28 2024 UTC