php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #62219 5 intl tests fail in 5.3.14rc2
Submitted: 2012-06-04 00:52 UTC Modified: 2013-05-06 21:50 UTC
From: mattficken@php.net Assigned: cataphract (profile)
Status: Closed Package: intl (PECL)
PHP Version: 5.3Git-2012-06-04 (Git) OS: Windows
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: mattficken@php.net
New email:
PHP Version: OS:

 

 [2012-06-04 00:52 UTC] mattficken@php.net
Description:
------------
These 5 intl tests fail with 5.3.14rc2 on Windows, but pass with snapshot builds 
from the last couple months:

ext\intl\tests\bug62070.phpt
ext\intl\tests\collator_get_sort_key.phpt
ext\intl\tests\dateformat_calendars.phpt
ext\intl\tests\resourcebundle_traversable.phpt
ext\intl\tests\bug62081.phpt

All the intl tests have passed with snapshot builds for the few months and have 
passed with previous final release and QA builds.

It may have something to do with this commit:
Fix bug #62082

http://git.php.net/?p=php-
src.git;a=commitdiff;h=095f7fc965d6eaec6915b0af5b29accfab1703b3

Expected result:
----------------
ext\intl\tests\bug62070.diff
001+ 5%2F%3D%3DC%01%09%01%8F%08%00
001- 5%2F%3D%3DC%01%09%01%8F%08

ext\intl\tests\collator_get_sort_key.diff:
002+ key: %27%29%2B%01%07%01%07%00
002- key: %29%2B-%01%07%01%07%00
004+ key: %27%29-%01%07%01%07%00
004- key: %29%2B%2F%01%07%01%07%00
006+ key: %27%27%27%01%07%01%07%00
006- key: %29%29%29%01%07%01%07%00
008+ key: %5C%0A%0A%01%06%01%06%00
008- key: _++%01%06%01%06%00
010+ key: %5C%0A%01%05%01%05%00
010- key: _+%01%05%01%05%00
012+ key: Y%01%05%01%05%00
013+ source: 
012- key: %5B%01%05%01%05%00
013- source:
015+ source: 
015- source:
018+ key: %18%01%05%01%05%00
018- key: %26%80%01%05%01%05%00
020+ key: W%01%05%01%05%00
020- key: Y%01%05%01%05%00
022+ key: 7%01%05%01%05%00
022- key: 9%01%05%01%05%00
024+ key: %3B%01%05%01%05%00
024- key: %3D%01%05%01%05%00
026+ key: %5C%0A%16%1A%01%07%01%07%00
026- key: _+%2C0%01%07%01%07%00
028+ key: %5C%0A%16%18%01%07%01%07%00
028- key: _+%2C.%01%07%01%07%00
030+ key: %5C%3A%3A%3A%01%07%01%07%00
030- key: _LLL%01%07%01%07%00
032+ key: %5D%3B%3FE%01%07%01%07%00
032- key: %60%05%09%0B%01%07%01%07%00
034+ key: %5C%0A%16%1A%01%07%01%07%00
034- key: _+%2C0%01%07%01%07%00
036+ key: %5C%0A%16%18%01%07%01%07%00
036- key: _+%2C.%01%07%01%07%00
038+ key: %5C%3A%3A%3A%01%07%01%07%00
038- key: _LLL%01%07%01%07%00
040+ key: %5D%3B%3FE%01%07%01%07%00
040- key: %60%05%09%0B%01%07%01%07%00

ext\intl\tests\dateformat_calendars.diff
004- 
005- Warning: IntlDateFormatter::__construct(): datefmt_create: invalid value 
for calendar type; it must be one of IntlDateFormatter::TRADITIONAL (locale's 
default calendar) or IntlDateFormatter::GREGORIAN in %s on line %d

ext\intl\tests\resourcebundle_traversable.diff
001+ bool(false)
002+ 
003+ Catchable fatal error: Argument 1 passed to iterator_to_array() must 
implement interface Traversable, instance of ResourceBundle given in C:\php-
sdk\php-test-pack-5.3-nts-windows-vc9-x86-
ra331f43\ext\intl\tests\resourcebundle_traversable.php on line 7
001- bool(true)
002- array(3) {
003-   [0]=>
004-   string(8) "cadena 1"
005-   [1]=>
006-   string(8) "cadena 2"
007-   [2]=>
008-   string(8) "cadena 3"
009- }

ext\intl\tests\bug62081.diff
001- Warning: IntlDateFormatter::__construct(): datefmt_create: cannot call 
constructor twice in %s on line %d



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-06-04 07:01 UTC] cataphract@php.net
Which version of ICU are you using?
 [2012-06-04 07:01 UTC] cataphract@php.net
-Package: ICONV related +Package: intl -Assigned To: +Assigned To: cataphract
 [2012-06-04 07:36 UTC] stas@php.net
ICU tests are very hard to make work reliably across versions and OSes :( 
Different versions have different capabilities and results.
 [2012-06-04 07:51 UTC] mattficken@php.net
5.3.14rc2 for Windows uses ICU 4.6.1.

Windows snapshot builds also use ICU 4.6.1, however the tests pass on them.

The intl tests pass on snapshot builds and passed on 5.3.14rc1. The failures are 
new just in 5.3.14rc2 (a regression).
 [2012-06-06 13:05 UTC] cataphract@php.net
All tests pass on Linux 32-bit with ICU 4.8.
 [2012-06-06 18:37 UTC] mattficken@php.net
These tests seem to be genuine failures:
ext\intl\tests\dateformat_calendars.phpt
ext\intl\tests\resourcebundle_traversable.phpt
ext\intl\tests\bug62081.phpt

But what about these two?
ext\intl\tests\bug62070.phpt 
ext\intl\tests\collator_get_sort_key.phpt

ext/intl/tests/bug62082.phpt is a new test, but passes on Windows/ICU 4.6.

The rest of these tests have been passsing on Windows before 5.3.14rc2.
 [2012-06-07 18:58 UTC] mattficken@php.net
Looks like commit http://git.php.net/?p=php-src.git;a=commit;h=758f0686d41cd39176f5055c50f0b094580cbbf0

may have fixed:
ext\intl\tests\collator_get_sort_key.phpt
ext\intl\tests\dateformat_calendars.phpt
ext\intl\tests\bug62081.phpt

I haven't tested it. Was this commit to fix these tests for ICU < 4.8 (ex: 4.6.1)?

What about ext\intl\tests\bug62070.phpt and ext\intl\tests\resourcebundle_traversable.phpt?
 [2013-05-06 21:50 UTC] mattficken@php.net
-Status: Assigned +Status: Closed
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Dec 04 17:01:23 2020 UTC