php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #62053 3.x.x not working 2.3.0 works
Submitted: 2012-05-17 11:52 UTC Modified: 2013-02-18 00:35 UTC
Votes:4
Avg. Score:4.0 ± 1.7
Reproduced:2 of 2 (100.0%)
Same Version:1 (50.0%)
Same OS:1 (50.0%)
From: jp at jpkvideo dot com Assigned:
Status: No Feedback Package: imagick (PECL)
PHP Version: 5.3.13 OS: Cent OS
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jp at jpkvideo dot com
New email:
PHP Version: OS:

 

 [2012-05-17 11:52 UTC] jp at jpkvideo dot com
Description:
------------
Not sure if this is a bug but I am unable to use version 3.0 or greater.
2.3.0 works though. Please Help!

Test script:
---------------
php -i | grep imagick

Expected result:
----------------
imagick
imagick module => enabled
imagick module version => 3.x.x
imagick classes => Imagick, ImagickDraw, ImagickPixel, ImagickPixelIterator
imagick.locale_fix => 0 => 0
imagick.progress_monitor => 0 => 0

Actual result:
--------------
PHP Warning:  PHP Startup: Unable to load dynamic library 
'/usr/lib64/php/modules/imagick.so' - /usr/lib64/php/modules/imagick.so: undefined 
symbol: MagickGetImageBluePrimary in Unknown on line 0

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-05-30 20:26 UTC] mkoppanen@php.net
What version of ImageMagick are you using?
 [2012-05-30 20:27 UTC] mkoppanen@php.net
-Status: Open +Status: Feedback
 [2013-02-18 00:35 UTC] pecl-dev at lists dot php dot net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.
 [2013-06-29 14:04 UTC] wlfantasy at gmail dot com
my php version : 5.1.6
situation:
I used to use imagemagick to edit images.Today i want to add support to webp 
with imagemagick.So i upgrade my imagemagick to version 6.8 and with option --
with-webp.I also installed libwebp version 0.3.1 .So far ,libwebp and 
imagemagick work perfactly. Next i need to reinstall imagick ,i tried imagick-
3.0.0 and imagick-3.0.1,install process success,but when i ran 'php -m|grep 
imagick',it shows:

PHP Warning:  PHP Startup: Unable to load dynamic library 
'/usr/lib64/php/modules/imagick.so' - /usr/lib64/php/modules/imagick.so: 
undefined symbol: MagickGetImageBluePrimary in Unknown on line 0

i choose imagick-2.3.0 as other said.Surely it works.
But i don't know why imagick-3.0.0 does not work,so the imagick-3.0.1.
I guess it cause by webp support. Is it true ??
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri Jul 30 11:01:23 2021 UTC