php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #62030 Advanced bugs search is broken.
Submitted: 2012-05-14 16:02 UTC Modified: 2012-05-14 21:58 UTC
From: zyss at mail dot zp dot ua Assigned:
Status: Wont fix Package: Website problem
PHP Version: Irrelevant OS: All
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please — but make sure to vote on the bug!
Your email address:
MUST BE VALID
Solve the problem:
30 - 21 = ?
Subscribe to this entry?

 
 [2012-05-14 16:02 UTC] zyss at mail dot zp dot ua
Description:
------------
When trying to use advanced search on bugs.php.net the following error appears:

Request-URI Too Large

The requested URL's length exceeds the capacity limit for this server.
Apache/2.2.14 (Ubuntu) Server at bugs-test.php.net Port 443

The problem is with select boxes, when many options are selected, form generates a long list of query parameters.

Why not to use a POST request?

Test script:
---------------
https://bugs.php.net/search.php?search_for=&boolean=0&limit=90&order_by=id&direction=DESC&cmd=display&status=All&bug_type=All&project=All&package_name%5B%5D=*General+Issues&package_name%5B%5D=Doc+Build+problem&package_name%5B%5D=Documentation+problem&package_name%5B%5D=Translation+problem&package_name%5B%5D=Feature%2FChange+Request&package_name%5B%5D=Filter+related&package_name%5B%5D=Online+Doc+Editor+problem&package_name%5B%5D=Output+Control&package_name%5B%5D=PDO+related&package_name%5B%5D=Performance+problem&package_name%5B%5D=PHAR+related&package_name%5B%5D=PHP-GTK+related&package_name%5B%5D=Systems+problem&package_name%5B%5D=Website+problem&package_name%5B%5D=Reflection+related&package_name%5B%5D=Reproducible+crash&package_name%5B%5D=Scripting+Engine+problem&package_name%5B%5D=Session+related&package_name%5B%5D=SPL+related&package_name%5B%5D=Streams+related&package_name%5B%5D=Testing+related&package_name%5B%5D=*Compile+Issues&package_name%5B%5D=Compile+Failure&package_name%5B%5D=Compile+Warning&package_name%5B%5D=*Configuration+Issues&package_name%5B%5D=Dynamic+loading&package_name%5B%5D=PHP+options%2Finfo+functions&package_name%5B%5D=Safe+Mode%2Fopen_basedir&package_name%5B%5D=Windows+Installer&package_name%5B%5D=*Web+Server+problem&package_name%5B%5D=Apache+related&package_name%5B%5D=Apache2+related&package_name%5B%5D=CGI%2FCLI+related&package_name%5B%5D=FPM+related&package_name%5B%5D=IIS+related&package_name%5B%5D=iPlanet+related&package_name%5B%5D=Other+web+server&package_name%5B%5D=Built-in+web+server&package_name%5B%5D=PWS+related&package_name%5B%5D=Servlet+related&package_name%5B%5D=*Calendar+problems&package_name%5B%5D=Calendar+related&package_name%5B%5D=Date%2Ftime+related&package_name%5B%5D=*Compression+related&package_name%5B%5D=Bzip2+Related&package_name%5B%5D=Zip+Related&package_name%5B%5D=Zlib+related&package_name%5B%5D=*Directory%2FFilesystem+functions&package_name%5B%5D=Directory+function+related&package_name%5B%5D=Filesystem+function+related&package_name%5B%5D=*Directory+Services+problems&package_name%5B%5D=LDAP+related&package_name%5B%5D=*Database+Functions&package_name%5B%5D=Adabas-D+related&package_name%5B%5D=dBase+related&package_name%5B%5D=DBM%2FDBA+related&package_name%5B%5D=DBX+related&package_name%5B%5D=FrontBase+related&package_name%5B%5D=Informix+related&package_name%5B%5D=Ingres+II+related&package_name%5B%5D=InterBase+related&package_name%5B%5D=mSQL+related&package_name%5B%5D=MSSQL+related&package_name%5B%5D=MySQL+related&package_name%5B%5D=MySQLi+related&package_name%5B%5D=OCI8+related&package_name%5B%5D=ODBC+related&package_name%5B%5D=Oracle+related&package_name%5B%5D=PostgreSQL+related&package_name%5B%5D=Solid+related&package_name%5B%5D=SQLite+related&package_name%5B%5D=Sybase+%28dblib%29+related&package_name%5B%5D=Sybase-ct+%28ctlib%29+related&package_name%5B%5D=*Data+Exchange+functions&package_name%5B%5D=JSON+related&package_name%5B%5D=WDDX+related&package_name%5B%5D=*Extensibility+Functions&package_name%5B%5D=COM+related&package_name%5B%5D=Java+related&package_name%5B%5D=ncurses+related&package_name%5B%5D=PCNTL+related&package_name%5B%5D=POSIX+related&package_name%5B%5D=Program+Execution&package_name%5B%5D=Readline+related&package_name%5B%5D=Semaphore+related&package_name%5B%5D=Win32API+related&package_name%5B%5D=*Graphics+related&package_name%5B%5D=EXIF+related&package_name%5B%5D=GD+related&package_name%5B%5D=GetImageSize+related&package_name%5B%5D=Ming+related&package_name%5B%5D=*Languages%2FTranslation&package_name%5B%5D=Gettext+related&package_name%5B%5D=ICONV+related&package_name%5B%5D=mbstring+related&package_name%5B%5D=Recode+related&package_name%5B%5D=*Mail+Related&package_name%5B%5D=IMAP+related&package_name%5B%5D=Mail+related&package_name%5B%5D=*Math+Functions&package_name%5B%5D=BC+math+related&package_name%5B%5D=GNU+MP+related&package_name%5B%5D=Math+related&package_name%5B%5D=*Encryption+and+hash+functions&package_name%5B%5D=hash+related&package_name%5B%5D=mcrypt+related&package_name%5B%5D=mhash+related&package_name%5B%5D=OpenSSL+related&package_name%5B%5D=*Network+Functions&package_name%5B%5D=FTP+related&package_name%5B%5D=HTTP+related&package_name%5B%5D=Network+related&package_name%5B%5D=SNMP+related&package_name%5B%5D=Sockets+related&package_name%5B%5D=*PDF+functions&package_name%5B%5D=ClibPDF+related&package_name%5B%5D=FDF+related&package_name%5B%5D=PDF+related&package_name%5B%5D=*Programming+Data+Structures&package_name%5B%5D=Arrays+related&package_name%5B%5D=Class%2FObject+related&package_name%5B%5D=Strings+related&package_name%5B%5D=Variables+related&package_name%5B%5D=*Regular+Expressions&package_name%5B%5D=PCRE+related&package_name%5B%5D=Regexps+related&package_name%5B%5D=*Spelling+functions&package_name%5B%5D=Enchant+related&package_name%5B%5D=Pspell+related&package_name%5B%5D=*XML+functions&package_name%5B%5D=DOM+XML+related&package_name%5B%5D=SimpleXML+related&package_name%5B%5D=SOAP+related&package_name%5B%5D=Tidy&package_name%5B%5D=XML+Reader&package_name%5B%5D=XML+related&package_name%5B%5D=XML+Writer&package_name%5B%5D=XMLRPC-EPI+related&package_name%5B%5D=XSLT+related&package_name%5B%5D=*URL+Functions&package_name%5B%5D=cURL+related&package_name%5B%5D=URL+related&package_name%5B%5D=*Unicode+Issues&package_name%5B%5D=I18N+and+L10N+related&package_name%5B%5D=Unicode+Engine+related&package_name%5B%5D=Unknown%2FOther+Function&package_name%5B%5D=PECL&package_name%5B%5D=amfext&package_name%5B%5D=amqp&package_name%5B%5D=APC&package_name%5B%5D=apd&package_name%5B%5D=APM&package_name%5B%5D=archive&package_name%5B%5D=automap&package_name%5B%5D=axis2&package_name%5B%5D=bbcode&package_name%5B%5D=bcompiler&package_name%5B%5D=big_int&package_name%5B%5D=BLENC&package_name%5B%5D=bloomy&package_name%5B%5D=bz2&package_name%5B%5D=cairo&package_name%5B%5D=cairo_wrapper&package_name%5B%5D=chdb&package_name%5B%5D=cld&package_name%5B%5D=clucene&package_name%5B%5D=coin_acceptor&package_name%5B%5D=colorer&package_name%5B%5D=crack&package_name%5B%5D=cvsclient&package_name%5B%5D=cybercash&package_name%5B%5D=cyrus&package_name%5B%5D=date_time&package_name%5B%5D=dbase&package_name%5B%5D=DBDO&package_name%5B%5D=dbplus&package_name%5B%5D=DBus&package_name%5B%5D=dbx&package_name%5B%5D=dio&package_name%5B%5D=docblock&package_name%5B%5D=domxml&package_name%5B%5D=drizzle&package_name%5B%5D=DTrace&package_name%5B%5D=ecasound&package_name%5B%5D=eio&package_name%5B%5D=enchant&package_name%5B%5D=esmtp&package_name%5B%5D=event&package_name%5B%5D=expect&package_name%5B%5D=fann&package_name%5B%5D=ffi&package_name%5B%5D=Fileinfo&package_name%5B%5D=filter&package_name%5B%5D=fpdf&package_name%5B%5D=FreeImage&package_name%5B%5D=fribidi&package_name%5B%5D=funcall&package_name%5B%5D=fuse&package_name%5B%5D=GDChart&package_name%5B%5D=gearman&package_name%5B%5D=geoip&package_name%5B%5D=gmagick&package_name%5B%5D=gnupg&package_name%5B%5D=gupnp&package_name%5B%5D=haru&package_name%5B%5D=hash&package_name%5B%5D=hidef&package_name%5B%5D=html_parse&package_name%5B%5D=htscanner&package_name%5B%5D=ibm_db2&package_name%5B%5D=id3&package_name%5B%5D=idn&package_name%5B%5D=igbinary&package_name%5B%5D=imagick&package_name%5B%5D=imlib2&package_name%5B%5D=inclued&package_name%5B%5D=informix&package_name%5B%5D=ingres&package_name%5B%5D=inotify&package_name%5B%5D=intercept&package_name%5B%5D=intl&package_name%5B%5D=isis&package_name%5B%5D=json&package_name%5B%5D=kadm5&package_name%5B%5D=KTaglib&package_name%5B%5D=lapack&package_name%5B%5D=lchash&package_name%5B%5D=libevent&package_name%5B%5D=lua&package_name%5B%5D=lzf&package_name%5B%5D=mailparse&package_name%5B%5D=markdown&package_name%5B%5D=maxdb&package_name%5B%5D=mcve&package_name%5B%5D=mdbtools&package_name%5B%5D=memcache&package_name%5B%5D=memcached&package_name%5B%5D=memtrack&package_name%5B%5D=meta&package_name%5B%5D=ming&package_name%5B%5D=mnogosearch&package_name%5B%5D=mogilefs&package_name%5B%5D=mongo&package_name%5B%5D=mono&package_name%5B%5D=mqseries&package_name%5B%5D=mysql&package_name%5B%5D=mysqlnd_ms&package_name%5B%5D=mysqlnd_qc&package_name%5B%5D=mysqlnd_uh&package_name%5B%5D=ncurses&package_name%5B%5D=newt&package_name%5B%5D=oauth&package_name%5B%5D=oci8&package_name%5B%5D=oggvorbis&package_name%5B%5D=openal&package_name%5B%5D=operator&package_name%5B%5D=optimizer&package_name%5B%5D=PAM&package_name%5B%5D=panda&package_name%5B%5D=Paradox&package_name%5B%5D=params&package_name%5B%5D=Parse_Tree&package_name%5B%5D=parsekit&package_name%5B%5D=pcsc&package_name%5B%5D=pdflib&package_name%5B%5D=PDO&package_name%5B%5D=PDO_4D&package_name%5B%5D=PDO_DBLIB&package_name%5B%5D=PDO_FIREBIRD&package_name%5B%5D=PDO_IBM&package_name%5B%5D=PDO_INFORMIX&package_name%5B%5D=PDO_MYSQL&package_name%5B%5D=PDO_OCI&package_name%5B%5D=PDO_ODBC&package_name%5B%5D=PDO_PGSQL&package_name%5B%5D=PDO_SQLITE&package_name%5B%5D=pdo_sqlsrv&package_name%5B%5D=pdo_user&package_name%5B%5D=PECL+bug+system&package_name%5B%5D=PECL+website&package_name%5B%5D=PECL_Gen&package_name%5B%5D=pecl_http&package_name%5B%5D=perforce&package_name%5B%5D=perl&package_name%5B%5D=phar&package_name%5B%5D=PHK&package_name%5B%5D=PHPScript&package_name%5B%5D=POP3&package_name%5B%5D=printer&package_name%5B%5D=proctitle&package_name%5B%5D=ps&package_name%5B%5D=python&package_name%5B%5D=radius&package_name%5B%5D=rar&package_name%5B%5D=rpmreader&package_name%5B%5D=rrd&package_name%5B%5D=runkit&package_name%5B%5D=sam&package_name%5B%5D=sasl&package_name%5B%5D=SCA_SDO&package_name%5B%5D=scream&package_name%5B%5D=shape&package_name%5B%5D=solr&package_name%5B%5D=sphinx&package_name%5B%5D=spidermonkey&package_name%5B%5D=SPL&package_name%5B%5D=SPL_Types&package_name%5B%5D=spread&package_name%5B%5D=SQLite&package_name%5B%5D=sqlite3&package_name%5B%5D=sqlsrv&package_name%5B%5D=ssdeep&package_name%5B%5D=ssh2&package_name%5B%5D=statgrab&package_name%5B%5D=stats&package_name%5B%5D=stem&package_name%5B%5D=stomp&package_name%5B%5D=sundown&package_name%5B%5D=svn&package_name%5B%5D=swish&package_name%5B%5D=syck&package_name%5B%5D=taint&package_name%5B%5D=tcpwrap&package_name%5B%5D=tdb&package_name%5B%5D=threads&package_name%5B%5D=tidy&package_name%5B%5D=timezonedb&package_name%5B%5D=tk&package_name%5B%5D=tokyo_tyrant&package_name%5B%5D=translit&package_name%5B%5D=unicodestring&package_name%5B%5D=uploadprogress&package_name%5B%5D=uuid&package_name%5B%5D=v8js&package_name%5B%5D=Valkyrie&package_name%5B%5D=varnish&package_name%5B%5D=vld&package_name%5B%5D=vpopmail&package_name%5B%5D=WBXML&package_name%5B%5D=Weakref&package_name%5B%5D=win32ps&package_name%5B%5D=win32service&package_name%5B%5D=win32std&package_name%5B%5D=WinBinder&package_name%5B%5D=WinCache&package_name%5B%5D=xattr&package_name%5B%5D=Xdebug&package_name%5B%5D=xdiff&package_name%5B%5D=xhprof&package_name%5B%5D=xmlReader&package_name%5B%5D=xmlwriter&package_name%5B%5D=xmms&package_name%5B%5D=xrange&package_name%5B%5D=xslcache&package_name%5B%5D=yaf&package_name%5B%5D=yami&package_name%5B%5D=yaml&package_name%5B%5D=yaz&package_name%5B%5D=yp&package_name%5B%5D=zip&package_name%5B%5D=*E-commerce+functions&package_name%5B%5D=Verisign+Payflow+Pro+related&package_name%5B%5D=Security+related&package_name%5B%5D=Disabled+packages&package_name%5B%5D=FrontPage+related&package_name%5B%5D=*Function+Specific&package_name%5B%5D=Installation+problem&package_name%5B%5D=Livedocs+problem&package_name%5B%5D=Misbehaving+function&package_name%5B%5D=mnoGoSearch+related&package_name%5B%5D=Other&package_name%5B%5D=Parser+error&package_name%5B%5D=PEAR+related&package_name%5B%5D=Sablotron+XSL&php_os=&phpver=&cve_id=&assign=&author_email=&bug_age=0&bug_updated=0

Expected result:
----------------
Search being done.

Actual result:
--------------
Request-URI Too Large

The requested URL's length exceeds the capacity limit for this server.
Apache/2.2.14 (Ubuntu) Server at bugs-test.php.net Port 443

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-05-14 16:04 UTC] bjori@php.net
-Status: Open +Status: Wont fix
 [2012-05-14 16:04 UTC] bjori@php.net
Because it makes it annoying to copy&paste the url.

Why would you be selecting the entire select box options anyway?
 [2012-05-14 16:32 UTC] zyss at mail dot zp dot ua
You don't have to copy&paste, just click it...

If you give the ability to select any number of options on your site then you're *responsible* for it to work properly. This is clearly a bug because it produces server error.

And again: why not to use POST request?
 [2012-05-14 21:58 UTC] bjori@php.net
Do it yourself if it bothers you: https://github.com/php/web-bugs

Keep in mind we would like to copy&paste the url to link to search results, and 
quickly modify search criteria while navigating the results.
 [2012-05-14 22:23 UTC] anon at anon dot anon
You can just leave the package name out and it will show you all of them:

https://bugs.php.net/search.php?limit=90&order_by=id&direction=DESC&cmd=display&status=All
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sun Jun 26 23:03:37 2022 UTC