php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #61989 PECL package "dio" will not compile against PHP-5.4.3
Submitted: 2012-05-10 10:11 UTC Modified: 2012-06-30 22:56 UTC
Votes:1
Avg. Score:4.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: tom at sl dot cm Assigned: cyberspice (profile)
Status: Closed Package: dio (PECL)
PHP Version: 5.4.3 OS: Linux (Gentoo)
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: tom at sl dot cm
New email:
PHP Version: OS:

 

 [2012-05-10 10:11 UTC] tom at sl dot cm
Description:
------------
PECL package "dio" will not compile against PHP-5.4.3.

https://gist.github.com/2652263

Expected result:
----------------
I expect the extension to be built.

Actual result:
--------------
https://gist.github.com/2652263

Patches

pecl-bug-61989.diff (last revision 2012-05-30 08:55 UTC by daniel dot mueller at inexio dot net)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-05-30 08:53 UTC] daniel dot mueller at inexio dot net
Same problem here.

The reason is, that since PHP 5.4.0, there is no safe mode, so the built fails.

I have prepared a patch for this issue, which restricts the safe_mode checks to php<5.4
 [2012-06-20 15:33 UTC] cyberspice@php.net
-Status: Open +Status: Assigned -Assigned To: +Assigned To: cyberspice
 [2012-06-30 22:55 UTC] cyberspice@php.net
-Status: Assigned +Status: Open
 [2012-06-30 22:56 UTC] cyberspice@php.net
-Status: Assigned +Status: Closed
 [2012-06-30 22:56 UTC] cyberspice@php.net
Fixed in 0.0.6.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Nov 28 08:03:16 2021 UTC