php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #61983 radius.c fails to compile under gcc 4.4
Submitted: 2012-05-09 14:34 UTC Modified: 2012-05-10 01:19 UTC
From: josh dot campbell at acsn dot co dot uk Assigned:
Status: Not a bug Package: radius (PECL)
PHP Version: 5.4.3 OS: CentOS 6.2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: josh dot campbell at acsn dot co dot uk
New email:
PHP Version: OS:

 

 [2012-05-09 14:34 UTC] josh dot campbell at acsn dot co dot uk
Description:
------------
/root/radius-1.2.5/radius.c:65: error: expected â=â, â,â, â;â, âasmâ or 
â__attribute__â before âradius_functionsâ

/root/radius-1.2.5/radius.c:102: error: âradius_functionsâ undeclared here (not in 
a function)

make: *** [radius.lo] Error 1


Test script:
---------------
N/A


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-05-09 15:22 UTC] josh dot campbell at acsn dot co dot uk
Fix:

diff radius.c radius.jas 
65c65
< function_entry radius_functions[] = {
---
> static zend_function_entry radius_functions[] = {
 [2012-05-10 01:19 UTC] felipe@php.net
-Status: Open +Status: Not a bug
 [2012-05-10 01:19 UTC] felipe@php.net
Try the SVN version, because a fix has been already committed, but no release done.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Nov 27 12:03:14 2021 UTC