|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #61880 Error symbol zif_uuid_variant: referenced symbol not found
Submitted: 2012-04-30 10:47 UTC Modified: 2015-04-12 04:22 UTC
Avg. Score:5.0 ± 0.0
Reproduced:0 of 1 (0.0%)
From: stephane dot picard at richemont dot com Assigned:
Status: No Feedback Package: uuid (PECL)
PHP Version: Irrelevant OS: Solaris 10
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please — but make sure to vote on the bug!
Your email address:
Solve the problem:
25 + 12 = ?
Subscribe to this entry?

 [2012-04-30 10:47 UTC] stephane dot picard at richemont dot com
Dear reader,
first time i am reporting a "bug" somewhere...
Not this much sure this is a bug of course. 
I am using the opencsw php_5.3.10 package on Solaris 10.
I'd like to add the PECL UUID extension (not provided by opencsw community).
I tried to use uuid-1.0.2 but got some compilation errors. Due to urgency i therefore tried to install the uuid-1.0.1 instead...which compiles and installs smoothly :

root@myhost> /opt/csw/bin/pecl install uuid-1.0.1
downloading uuid-1.0.1.tgz ...
Starting to download uuid-1.0.1.tgz (5,619 bytes)
.....done: 5,619 bytes
3 source files, building
WARNING: php_bin /opt/csw/php5/bin/php appears to have a suffix 5/bin/php, but config variable php_suffix does not match
running: phpize
Configuring for:
PHP Api Version:         20090626
Zend Module Api No:      20090626
Zend Extension Api No:   220090626 warning: prefer named diversions warning: prefer named diversions
building in /tmp/pear/temp/pear-build-defaultuserY4aOWe/uuid-1.0.1
running: /tmp/pear/temp/uuid/configure
checking for grep that handles long lines and -e... /opt/csw/bin/ggrep
checking for egrep... /opt/csw/bin/ggrep -E
checking for a sed that does not truncate output... /opt/csw/bin/gsed
checking for cc... no
checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking how to run the C preprocessor... gcc -E
checking for icc... no
checking for suncc... no
checking whether gcc and cc understand -c and -o together... yes
checking for system library directory... lib
checking if compiler supports -R... yes
checking build system type... i386-pc-solaris2.10
checking host system type... i386-pc-solaris2.10
checking target system type... i386-pc-solaris2.10
checking for PHP prefix... /opt/csw/php5
checking for PHP includes... -I/opt/csw/php5/include/php -I/opt/csw/php5/include/php/main -I/opt/csw/php5/include/php/TSRM -I/opt/csw/php5/include/php/Zend -I/opt/csw/php5/include/php/ext -I/opt/csw/php5/include/php/ext/date/lib
checking for PHP extension directory... /opt/csw/php5/lib/php/extensions/no-debug-non-zts-20090626
checking for PHP installed headers prefix... /opt/csw/php5/include/php
checking if debug is enabled... no
checking if zts is enabled... no
checking for re2c... no
configure: WARNING: You will need re2c 0.13.4 or later if you want to regenerate PHP parsers.
checking for gawk... gawk
checking for uuid support... yes, shared
checking for uuid_type in -luuid... no
checking for __uuid_type in -luuid... no
checking for uuid_variant in -luuid... no
checking for __uuid_variant in -luuid... no
checking for ld used by gcc... /usr/ccs/bin/ld
checking if the linker (/usr/ccs/bin/ld) is GNU ld... no
checking for /usr/ccs/bin/ld option to reload object files... -r
checking for BSD-compatible nm... /usr/ccs/bin/nm -p
checking whether ln -s works... yes
checking how to recognize dependent libraries... pass_all
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking dlfcn.h usability... yes
checking dlfcn.h presence... yes
checking for dlfcn.h... yes
checking the maximum length of command line arguments... 786240
checking command to parse /usr/ccs/bin/nm -p output from gcc object... ok
checking for objdir... .libs
checking for ar... no
checking for ranlib... no
checking for strip... no
checking if gcc supports -fno-rtti -fno-exceptions... no
checking for gcc option to produce PIC... -fPIC
checking if gcc PIC flag -fPIC works... yes
checking if gcc static flag -static works... no
checking if gcc supports -c -o file.o... yes
checking whether the gcc linker (/usr/ccs/bin/ld) supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... solaris2.10
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... no
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... no

creating libtool
appending configuration tag "CXX" to libtool
configure: creating ./config.status
config.status: creating config.h
running: make
/bin/bash /tmp/pear/temp/pear-build-defaultuserY4aOWe/uuid-1.0.1/libtool --mode=compile gcc  -I. -I/tmp/pear/temp/uuid -DPHP_ATOM_INC -I/tmp/pear/temp/pear-build-defaultuserY4aOWe/uuid-1.0.1/include -I/tmp/pear/temp/pear-build-defaultuserY4aOWe/uuid-1.0.1/main -I/tmp/pear/temp/uuid -I/opt/csw/php5/include/php -I/opt/csw/php5/include/php/main -I/opt/csw/php5/include/php/TSRM -I/opt/csw/php5/include/php/Zend -I/opt/csw/php5/include/php/ext -I/opt/csw/php5/include/php/ext/date/lib  -DHAVE_CONFIG_H  -g -O2   -c /tmp/pear/temp/uuid/uuid.c -o uuid.lo
mkdir .libs
 gcc -I. -I/tmp/pear/temp/uuid -DPHP_ATOM_INC -I/tmp/pear/temp/pear-build-defaultuserY4aOWe/uuid-1.0.1/include -I/tmp/pear/temp/pear-build-defaultuserY4aOWe/uuid-1.0.1/main -I/tmp/pear/temp/uuid -I/opt/csw/php5/include/php -I/opt/csw/php5/include/php/main -I/opt/csw/php5/include/php/TSRM -I/opt/csw/php5/include/php/Zend -I/opt/csw/php5/include/php/ext -I/opt/csw/php5/include/php/ext/date/lib -DHAVE_CONFIG_H -g -O2 -c /tmp/pear/temp/uuid/uuid.c  -fPIC -DPIC -o .libs/uuid.o
/bin/bash /tmp/pear/temp/pear-build-defaultuserY4aOWe/uuid-1.0.1/libtool --mode=link gcc -DPHP_ATOM_INC -I/tmp/pear/temp/pear-build-defaultuserY4aOWe/uuid-1.0.1/include -I/tmp/pear/temp/pear-build-defaultuserY4aOWe/uuid-1.0.1/main -I/tmp/pear/temp/uuid -I/opt/csw/php5/include/php -I/opt/csw/php5/include/php/main -I/opt/csw/php5/include/php/TSRM -I/opt/csw/php5/include/php/Zend -I/opt/csw/php5/include/php/ext -I/opt/csw/php5/include/php/ext/date/lib  -DHAVE_CONFIG_H  -g -O2   -o -export-dynamic -avoid-version -prefer-pic -module -rpath /tmp/pear/temp/pear-build-defaultuserY4aOWe/uuid-1.0.1/modules  uuid.lo -luuid
gcc -shared -Wl,-h -Wl, -o .libs/  .libs/uuid.o  -luuid
(cd .libs && rm -f && ln -s ../
/bin/bash /tmp/pear/temp/pear-build-defaultuserY4aOWe/uuid-1.0.1/libtool --mode=install cp ./ /tmp/pear/temp/pear-build-defaultuserY4aOWe/uuid-1.0.1/modules
cp ./.libs/ /tmp/pear/temp/pear-build-defaultuserY4aOWe/uuid-1.0.1/modules/
chmod +x /tmp/pear/temp/pear-build-defaultuserY4aOWe/uuid-1.0.1/modules/
cp ./.libs/uuid.lai /tmp/pear/temp/pear-build-defaultuserY4aOWe/uuid-1.0.1/modules/
Libraries have been installed in:

If you ever happen to want to link against installed libraries
in a given directory, LIBDIR, you must either use libtool, and
specify the full pathname of the library, or use the `-LLIBDIR'
flag during linking and do at least one of the following:
   - add LIBDIR to the `LD_LIBRARY_PATH' environment variable
     during execution
   - use the `-RLIBDIR' linker flag

See any operating system documentation about shared libraries for
more information, such as the ld(1) and manual pages.

Build complete.
Don't forget to run 'make test'.

running: make INSTALL_ROOT="/tmp/pear/temp/pear-build-defaultuserY4aOWe/install-uuid-1.0.1" install
Installing shared extensions:     /tmp/pear/temp/pear-build-defaultuserY4aOWe/install-uuid-1.0.1/opt/csw/php5/lib/php/extensions/no-debug-non-zts-20090626/
running: find "/tmp/pear/temp/pear-build-defaultuserY4aOWe/install-uuid-1.0.1" | xargs ls -dils
1714833949    8 drwxr-xr-x   3 root     root         177 Apr 30 12:19 /tmp/pear/temp/pear-build-defaultuserY4aOWe/install-uuid-1.0.1
1829101393    8 drwxr-xr-x   3 root     root         177 Apr 30 12:19 /tmp/pear/temp/pear-build-defaultuserY4aOWe/install-uuid-1.0.1/opt
1695241357    8 drwxr-xr-x   3 root     root         178 Apr 30 12:19 /tmp/pear/temp/pear-build-defaultuserY4aOWe/install-uuid-1.0.1/opt/csw
2027306152    8 drwxr-xr-x   3 root     root         177 Apr 30 12:19 /tmp/pear/temp/pear-build-defaultuserY4aOWe/install-uuid-1.0.1/opt/csw/php5
1832336152    8 drwxr-xr-x   3 root     root         177 Apr 30 12:19 /tmp/pear/temp/pear-build-defaultuserY4aOWe/install-uuid-1.0.1/opt/csw/php5/lib
2027205056    8 drwxr-xr-x   3 root     root         184 Apr 30 12:19 /tmp/pear/temp/pear-build-defaultuserY4aOWe/install-uuid-1.0.1/opt/csw/php5/lib/php
2177242477    8 drwxr-xr-x   3 root     root         199 Apr 30 12:19 /tmp/pear/temp/pear-build-defaultuserY4aOWe/install-uuid-1.0.1/opt/csw/php5/lib/php/extensions
2027816301    8 drwxr-xr-x   2 root     root         181 Apr 30 12:19 /tmp/pear/temp/pear-build-defaultuserY4aOWe/install-uuid-1.0.1/opt/csw/php5/lib/php/extensions/no-debug-non-zts-20090626
1831099561   64 -rwxr-xr-x   1 root     root       30316 Apr 30 12:19 /tmp/pear/temp/pear-build-defaultuserY4aOWe/install-uuid-1.0.1/opt/csw/php5/lib/php/extensions/no-debug-non-zts-20090626/

Build process completed successfully
Installing '/opt/csw/php5/lib/php/extensions/no-debug-non-zts-20090626/'
install ok: channel://
configuration option "php_ini" is not set to php.ini location
You should add "" to php.ini

but when i add the line "" to php.ini and restart apache i got the following error message :

[Mon Apr 30 10:23:16 2012] [notice] SIGHUP received.  Attempting to restart

PHP Warning:  PHP Startup: Unable to load dynamic library '/opt/csw/php5/lib/php/extensions/no-debug-non-zts-20090626/' - httpd.prefork: fatal: relocation error: file /opt/csw/php5/lib/php/extensions/no-debug-non-zts-20090626/ symbol zif_uuid_variant: referenced symbol not found in Unknown on line 0

Also checked about the lib dependancies but everything looks quiet :

root@myhost> ldd /opt/csw/php5/lib/php/extensions/no-debug-non-zts-20090626/ =>  /lib/ =>         /opt/csw/lib/ =>     /lib/ =>        /lib/ =>   /lib/ =>    /lib/ =>    /lib/ =>   /lib/ =>  /lib/ =>         /lib/ =>   /lib/ =>     /lib/

Could not find anything on the web... In case one of you have even a small idea i would be very grateful!
With Regards

Expected result:
Have the UUID php extension loaded

Actual result:
PHP Startup: Unable to load dynamic library '/opt/csw/php5/lib/php/extensions/no-debug-non-zts-20090626/'


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2015-04-04 05:27 UTC]
-Status: Open +Status: Feedback
 [2015-04-04 05:27 UTC]
Please test upcoming 1.0.4RC1 to confirm if this issue still exists.
 [2015-04-12 04:22 UTC] pecl-dev at lists dot php dot net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Re-Opened". Thank you.
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun Apr 14 17:01:28 2024 UTC