php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #61838 mysqli_get_cache_stats() does nothing
Submitted: 2012-04-24 14:19 UTC Modified: 2012-05-02 14:20 UTC
From: jpauli@php.net Assigned:
Status: Not a bug Package: MySQL related
PHP Version: 5.3.10 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jpauli@php.net
New email:
PHP Version: OS:

 

 [2012-04-24 14:19 UTC] jpauli@php.net
Description:
------------
mysqli_get_cache_stats() just return an empty array, always.
It has not been implemented, but it's documented :)

Test script:
---------------
See source code of mysqli_get_cache_stats(), it always returns an empty array, whatever happens

Expected result:
----------------
mysqli_get_cache_stats() returns useful data

Actual result:
--------------
mysqli_get_cache_stats() is useless actually

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-05-02 14:16 UTC] uw@php.net
Good find, but...

- it is marked as undocumented. Means, it can return pretty much anything, including nothing. 
- it is marked as deprecated. 

Whether this is sufficient or not, well, Docs team can decide on adding a note.I would say its OK as it is. Thus, setting to "not a bug".
 [2012-05-02 14:16 UTC] uw@php.net
-Status: Open +Status: Not a bug
 [2012-05-02 14:20 UTC] jpauli@php.net
So, there is no plan to implement this function at all ?
 [2015-08-25 07:24 UTC] accounts at dotmanila dot com
On 5.6.12, this when calling the function, it returns an error instead of an empty array. Documentation should be updated opened a doc bug here https://bugs.php.net/bug.php?id=70352
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Fri May 20 17:03:35 2022 UTC