php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #61821 Using ob_start() + zlib.output_compression makes it impossible to flush output
Submitted: 2012-04-23 00:32 UTC Modified: 2012-04-24 18:03 UTC
From: magicaltux@php.net Assigned: mike (profile)
Status: Not a bug Package: Zlib related
PHP Version: 5.4.0 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: magicaltux@php.net
New email:
PHP Version: OS:

 

 [2012-04-23 00:32 UTC] magicaltux@php.net
Description:
------------
When using ob_start() followed by a ini_set('zlib.output_compression', true), 
using ob_flush() won't output anything, even if no zlib compression will happen.

This is a new bug since PHP 5.4.0, maybe linked to #61820

Test script:
---------------
<?php

ob_start();

ini_set('zlib.output_compression', true);

echo "PHP VERSION ".phpversion()."\n";
ob_flush();
flush();

echo "You shouldn't have to wait to see me\n";
ob_flush();
flush();

sleep(5);


Expected result:
----------------
PHP VERSION 5.5.0-dev
You shouldn't have to wait to see me


Actual result:
--------------
PHP VERSION 5.5.0-dev
You shouldn't have to wait to see me


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-04-23 09:00 UTC] mike@php.net
-Status: Open +Status: Assigned -Assigned To: +Assigned To: mike
 [2012-04-24 18:03 UTC] mike@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

The first output buffer is still there holding your output...?

Try print_r(ob_get_status(true));
 [2012-04-24 18:03 UTC] mike@php.net
-Status: Assigned +Status: Not a bug
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Sep 26 00:01:24 2020 UTC