php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #61771 Fatal error: Call to undefined method mysqli_stmt::fetchAll() in /opt/lampp/ht
Submitted: 2012-04-19 05:34 UTC Modified: 2012-04-19 06:20 UTC
From: jckhunt4 at gmail dot com Assigned:
Status: Not a bug Package: PDO related
PHP Version: 5.4.0 OS: linux
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: jckhunt4 at gmail dot com
New email:
PHP Version: OS:

 

 [2012-04-19 05:34 UTC] jckhunt4 at gmail dot com
Description:
------------
---
From manual page: http://www.php.net/pdostatement.fetchall#refsect1-pdostatement.fetchall-examples
---

Fatal error: Call to undefined method mysqli_stmt::fetchAll() in /opt/lampp/htdocs/version5/ppc_audit_datafetch.php on line 1067



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-04-19 06:20 UTC] aharvey@php.net
You can't execute fetchAll() on a mysqli_stmt object. PDO is not the same thing as 
mysqli.

The documentation for mysqli_stmt can be found at: http://php.net/mysqli_stmt
 [2012-04-19 06:20 UTC] aharvey@php.net
-Status: Open +Status: Not a bug -Package: Streams related +Package: PDO related
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Tue Jul 16 16:01:27 2024 UTC