php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #61765 Empty archives
Submitted: 2012-04-18 15:11 UTC Modified: 2012-04-19 04:13 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: oden@php.net Assigned: crobin (profile)
Status: Closed Package: spidermonkey (PECL)
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: oden@php.net
New email:
PHP Version: OS:

 

 [2012-04-18 15:11 UTC] oden@php.net
Description:
------------
Hi,

Both http://pecl.php.net/get/spidermonkey-0.2.0.tgz and http://pecl.php.net/get/spidermonkey-0.2.1.tgz contains only the package.xml file, please fix :)

Test script:
---------------
nada

Expected result:
----------------
zip

Actual result:
--------------
null

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-04-18 18:21 UTC] Kevin_J_Nicholls at hotmail dot com
Experiencing the same thing.
 [2012-04-19 04:13 UTC] crobin@php.net
Thank you for your bug report. This issue has already been fixed
in the latest released version of PHP, which you can download at 
http://www.php.net/downloads.php

Sorry about that, fixed that in 1.0.0 (also bumped the version as pecl was 
complaining about it)
The empty archive was due to a bug in PHP 5.3.10/5.4 which bundles an old 
PEAR/Archive_Tar that generates invalid tar archives, the archive 
was not empty, but had an extra block appended to the first file that made the 
tar commmand think that the archive was finished: 
http://pear.php.net/bugs/bug.php?id=19289
 [2012-04-19 04:13 UTC] crobin@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: crobin
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Jul 15 17:01:26 2020 UTC