php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #61722 Timezone abbreviation
Submitted: 2012-04-13 13:35 UTC Modified: 2012-04-18 05:59 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: akbar6393222 at yahoo dot com Assigned:
Status: Not a bug Package: Date/time related
PHP Version: 5.3.10 OS: CentOS release 5.8 (Final)
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
15 + 9 = ?
Subscribe to this entry?

 
 [2012-04-13 13:35 UTC] akbar6393222 at yahoo dot com
Description:
------------
Timezone abbreviation wrong intepreted
it affecting on some region as on tested

Test script:
---------------
<?php
date_default_timezone_set("Asia/Jakarta");
echo date('T');


Expected result:
----------------
WIB

Actual result:
--------------
WIT

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-04-18 05:54 UTC] pajoye@php.net
-Package: date_time +Package: Date/time related
 [2012-04-18 05:54 UTC] pajoye@php.net
Move to the right extension.
 [2012-04-18 05:59 UTC] aharvey@php.net
The IANA time zone database (http://www.iana.org/time-zones) which PHP uses has 
the abbreviation listed as WIT. You'll need to have it fixed upstream, as we just 
pull it in from there.

Not a PHP bug: closing.
 [2012-04-18 05:59 UTC] aharvey@php.net
-Status: Open +Status: Not a bug
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Thu Nov 15 04:01:25 2018 UTC