php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #61690 \x22 is converted to " before parsing the json string
Submitted: 2012-04-10 16:44 UTC Modified: 2012-04-11 02:11 UTC
From: knives dot dev at gmail dot com Assigned:
Status: Not a bug Package: JSON related
PHP Version: 5.3Git-2012-04-10 (snap) OS: ubuntu linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: knives dot dev at gmail dot com
New email:
PHP Version: OS:

 

 [2012-04-10 16:44 UTC] knives dot dev at gmail dot com
Description:
------------
When decoding a json string that contains the hex code for double quote character (") it will not decode properly. I believe this is because it is converting it to a " before looking at the syntax and converting the json to php.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-04-11 02:11 UTC] aharvey@php.net
-Status: Open +Status: Not a bug -Package: json +Package: JSON related
 [2012-04-11 02:11 UTC] aharvey@php.net
JSON doesn't support \x escapes, so it's invalid JSON by definition, hence why json_decode() returns null. Decoding the valid JSON \u0022 works fine.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Jan 17 16:01:24 2020 UTC