php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #6163 Unable to compile with INFORMIX
Submitted: 2000-08-15 07:57 UTC Modified: 2001-06-02 20:11 UTC
From: paulg at barleychalu dot co dot uk Assigned:
Status: Closed Package: Informix related
PHP Version: 4.0.4 OS: SCO Openserver 5.0.4
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: paulg at barleychalu dot co dot uk
New email:
PHP Version: OS:

 

 [2000-08-15 07:57 UTC] paulg at barleychalu dot co dot uk
Hi team,

I'm getting the error listed below and 'ATTENTION - this may mess up ....' when trying to compile Informix support into PHP4 as an Apache module. I've done it many times with PHP3 but can't get it to work with version 4. PHP4 with Apache will build no trouble but as soon as the --with-informix is added it breaks. I know everything on the machine works because of having version 3 fully working.

It seems it's something to do with the libraries. When I add an IFX_LIBS="$INFORMIXDIR/lib/esql/libgen.a" just for testing for the configure stage the conftest seems to pass ok and no debug.log is produced but it still won't compile though. Must be something in this area.

I'll give any help I can to resolve this. It's either something silly or more likely because my os is SCO :o(

BTW, which supporting build programs(bison,flex ranlib etc) and versions are required to install version 4. I think some trouble with especially non-gnu platforms(like mine) is that not all the required programs are installed and this causes people trouble. Perhaps a list in the INSTALL file? Just a thought. 

Thanks for you help, 

- Paul -

System:
SCO Openserver (5.0.4)
PHP4 (4.0.1pl2) and a latest CVS(200008140245)
Apache (1.3.12)
gcc (2.95.2)

./configure --with-apache=../1.3.12 \
            --without-mysql \
            --with-informix=yes \
            --enable-track-vars

Debug.log
CONFIGURE:   './configure' '--with-apache=../apache_1.3.12' '--without-mysql' '--with-informix' '--enable-track-vars'
CC:         gcc
CFLAGS:     -g -O2 -I/usr/informix/incl/esql
CPPFLAGS:   
CXX:        
CXXFLAGS:   
INCLUDES:    -I/usr/src/apache_1.3.12/src/include -I/usr/src/apache_1.3.12/src/os/unix  -I$(top_builddir)/Zend -I$(top_srcdir)  -I/usr/informix/incl/esql
LDFLAGS:     -L/usr/informix/lib -L/usr/informix/lib -L/usr/informix/lib/esql -L/usr/informix/lib/esql  -L/usr/src/php4-200008140245/ext/informix -L/usr/src/php4-200008140245/ext/informix
LIBS:       -lm -lcrypt -lsocket  -lsocket -lifsql -lifasf -lifgen -lifos -lifgls -lnsl_s -lcrypt_i -lsocket -lnsl -lsuds -ltinfo -lprot -lx -ltinfo -lphp_ifx -lifglx
DLIBS:      
SAPI:       apache
PHP_RPATHS:  /usr/informix/lib /usr/informix/lib/esql /usr/src/php4-200008140245/ext/informix
uname -a:   SCO_SV barley 3.2 2 i386

gcc -o conftest -g -O2 -I/usr/informix/incl/esql   -L/usr/informix/lib -L/usr/informix/lib -L/usr/informix/lib/esql -L/usr/informix/lib/esql  -L/usr/src/php4-200008140245/ext/informix -L/usr/src/php4-200008140245/ext/informix conftest.c -lm -lcrypt -lsocket  -lsocket -lifsql -lifasf -lifgen -lifos -lifgls -lnsl_s -lcrypt_i -lsocket -lnsl -lsuds -ltinfo -lprot -lx -ltinfo -lphp_ifx -lifglx 1>&5
Undefined			first referenced
 symbol  			    in file
ceil                                /usr/informix/lib/esql/libifsql.so
getspnam                            /usr/informix/lib/esql/libifos.so
log                                 /lib/libprot.so
fabs                                /usr/informix/lib/esql/libifgen.so
conftest: fatal error: Symbol referencing errors. No output written to conftest
collect2: ld returned 1 exit status


Error Ouput:
gcc -DHAVE_CONFIG_H -I. -I/usr/src/php-4.0.1pl2/ext/informix -I/usr/src/php-
4.0.
1pl2 -I/usr/src/php-4.0.1pl2/main -I/usr/src/apache_1.3.12/src/include -I/us
r/sr
c/apache_1.3.12/src/os/unix -I/usr/src/php-4.0.1pl2/Zend -I/usr/src/php-4.0.
1pl2
 -I/usr/informix/incl/esql -I/usr/src/php-4.0.1pl2/ext/xml/expat/xmltok -I/u
sr/s
rc/php-4.0.1pl2/ext/xml/expat/xmlparse  -DXML_BYTE_ORDER=21 -I/usr/informix/
incl
/esql -I/usr/informix/incl/esql  -c ifx.c && touch ifx.lo
/bin/sh /usr/src/php-4.0.1pl2/libtool --silent --mode=link
gcc -I/usr/informix/i
ncl/esql -I/usr/informix/incl/esql   -o libinformix.la  ifx.lo
/usr/lib/libgen.a

libtool: link: cannot build libtool library `libinformix.la' from
non-libtool ob
jects: /usr/lib/libgen.a

gmake[3]: *** [libinformix.la] Error 1
gmake[3]: Leaving directory `/usr/src/php-4.0.1pl2/ext/informix'
gmake[2]: *** [all-recursive] Error 1
gmake[2]: Leaving directory `/usr/src/php-4.0.1pl2/ext/informix'
gmake[1]: *** [all-recursive] Error 1
gmake[1]: Leaving directory `/usr/src/php-4.0.1pl2/ext'
gmake: *** [all-recursive] Error 1


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-12-18 10:58 UTC] sniper@php.net
Please try the latest snapshot from http://snaps.php.net/
to verify if this bug still exists.

--Jani
 [2000-12-20 18:54 UTC] sniper@php.net
User reported: Happens with 4.0.4 too.

--Jani
 [2001-06-01 02:58 UTC] sniper@php.net
Does this happen with PHP 4.0.5 ?
( I think this not anything in PHP but in your system
that is wrong though)

--Jani

 [2001-06-02 20:11 UTC] sniper@php.net
This should be fixed with PHP 4.0.6, please try the 
latest release candidate:

http://www.php.net/~andi/php-4.0.6RC2.tar.gz

-Jani

 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Wed Nov 14 11:01:25 2018 UTC