php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #61618 GeoIP City Edition has invalid filename
Submitted: 2012-04-04 08:13 UTC Modified: 2012-04-04 23:21 UTC
From: max at kriegt dot es Assigned:
Status: Not a bug Package: geoip (PECL)
PHP Version: 5.4.0 OS: Debian 6.0.1
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: max at kriegt dot es
New email:
PHP Version: OS:

 

 [2012-04-04 08:13 UTC] max at kriegt dot es
Description:
------------
The GeoIP City Edition, Rev 1 has an invalid filename.
The File provided by maxmind is named "GeoLiteCity.dat", in 
geoip_db_get_all_info(); we get "GeoIPCity.dat".

I just created a symlink called "GeoIPCity.dat" pointing on "GeoLiteCity.dat" and 
it worked as it should.

Test script:
---------------
<?php
$databases = geoip_db_get_all_info();
$geoLiteCity = $databases[2];

print $geoLiteCity['filename'] . PHP_EOL;
?>

Expected result:
----------------
/usr/share/GeoIP/GeoLitecity.dat

Actual result:
--------------
/usr/share/GeoIP/GeoIPCity.dat

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-04-04 08:14 UTC] max at kriegt dot es
Expected result:
----------------
/usr/share/GeoIP/GeoLiteCity.dat
 [2012-04-04 08:15 UTC] max at kriegt dot es
-Status: Open +Status: Closed
 [2012-04-04 08:15 UTC] max at kriegt dot es
I recently realized that the non-Lite version provides GeoIPCity.dat...
 [2012-04-04 23:21 UTC] ohill@php.net
-Status: Closed +Status: Not a bug
 [2012-04-04 23:21 UTC] ohill@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Jan 24 05:01:23 2020 UTC