php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #61600 when install sphinx from pecl recieve error
Submitted: 2012-04-02 11:28 UTC Modified: 2012-04-03 09:29 UTC
From: ciociocio2 at mail dot ru Assigned: tony2001 (profile)
Status: Closed Package: sphinx (PECL)
PHP Version: 5.4.0 OS: ubuntu 12.04
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: ciociocio2 at mail dot ru
New email:
PHP Version: OS:

 

 [2012-04-02 11:28 UTC] ciociocio2 at mail dot ru
Description:
------------
before install sphinx 2.0.4 from deb and libsearchclient from this package
on next step 
sudo pecl install sphinx
and recieve this error:

/bin/bash /tmp/pear/temp/pear-build-rootAWwIJD/sphinx-1.1.0/libtool --
mode=compile cc  -I. -I/tmp/pear/temp/sphinx -DPHP_ATOM_INC -
I/tmp/pear/temp/pear-build-rootAWwIJD/sphinx-1.1.0/include -
I/tmp/pear/temp/pear-build-rootAWwIJD/sphinx-1.1.0/main -I/tmp/pear/temp/sphinx 
-I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -
I/usr/include/php5/Zend -I/usr/include/php5/ext -I/usr/include/php5/ext/date/lib 
-I/usr/local/include  -DHAVE_CONFIG_H  -g -O2   -c 
/tmp/pear/temp/sphinx/sphinx.c -o sphinx.lo
libtool: compile:  cc -I. -I/tmp/pear/temp/sphinx -DPHP_ATOM_INC -
I/tmp/pear/temp/pear-build-rootAWwIJD/sphinx-1.1.0/include -
I/tmp/pear/temp/pear-build-rootAWwIJD/sphinx-1.1.0/main -I/tmp/pear/temp/sphinx 
-I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -
I/usr/include/php5/Zend -I/usr/include/php5/ext -I/usr/include/php5/ext/date/lib 
-I/usr/local/include -DHAVE_CONFIG_H -g -O2 -c /tmp/pear/temp/sphinx/sphinx.c  -
fPIC -DPIC -o .libs/sphinx.o
/tmp/pear/temp/sphinx/sphinx.c: In function 'zim_SphinxClient_setRankingMode':
/tmp/pear/temp/sphinx/sphinx.c:772:2: error: too few arguments to function 
'sphinx_set_ranking_mode'
/usr/local/include/sphinxclient.h:206:17: note: declared here
/tmp/pear/temp/sphinx/sphinx.c: In function 'zim_SphinxClient_updateAttributes':
/tmp/pear/temp/sphinx/sphinx.c:1040:6: warning: passing argument 2 of 'memset' 
makes integer from pointer without a cast [enabled by default]
/usr/include/x86_64-linux-gnu/bits/string3.h:77:1: note: expected 'int' but 
argument is of type 'void *'
make: *** [sphinx.lo] Error 1
ERROR: `make' failed



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-04-02 13:17 UTC] tony2001@php.net
Please try using this snapshot:

  http://snaps.php.net/php-trunk-latest.tar.gz
 
For Windows:

  http://windows.php.net/snapshots/

Duplicate of bug #61392.
 [2012-04-02 13:17 UTC] tony2001@php.net
-Status: Open +Status: Feedback
 [2012-04-03 09:29 UTC] tony2001@php.net
-Status: Feedback +Status: Closed -Assigned To: +Assigned To: tony2001
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Nov 30 03:03:16 2021 UTC