php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #61437 Illegal stub for phar
Submitted: 2012-03-19 15:50 UTC Modified: 2012-03-22 13:01 UTC
From: nison dot mael at gmail dot com Assigned:
Status: Not a bug Package: PHAR related
PHP Version: 5.3.10 OS: Archlinux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: nison dot mael at gmail dot com
New email:
PHP Version: OS:

 

 [2012-03-19 15:50 UTC] nison dot mael at gmail dot com
Description:
------------
It's not possible to add spaces in the __halt_compiler argument list.

Test script:
---------------
<?php $phar->setStub( "<?php __HALT_COMPILER( );" );

Expected result:
----------------
Works

Actual result:
--------------
Fatal error: Uncaught exception 'PharException' with message 'illegal stub for 
phar "/tmp/foo.phar"' in /tmp/compile.php:21


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-03-22 13:01 UTC] iliaa@php.net
-Status: Open +Status: Not a bug
 [2012-03-22 13:01 UTC] iliaa@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Aug 09 18:34:40 2020 UTC