php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #61429 php54-svn build ignores '--enable-static=no --enable-<ext>=shared' flags
Submitted: 2012-03-18 16:26 UTC Modified: 2013-02-18 00:35 UTC
From: locuse at mm dot st Assigned:
Status: No Feedback Package: *Compile Issues
PHP Version: 5.4SVN-2012-03-18 (SVN) OS: linux x86_64
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: locuse at mm dot st
New email:
PHP Version: OS:

 

 [2012-03-18 16:26 UTC] locuse at mm dot st
Description:
------------
i'm building php5.4 from source,

	cd PHP_5_4
	svn info
		URL: https://svn.php.net/repository/php/php-src/branches/PHP_5_4
		Repository Root: https://svn.php.net/repository
		Repository UUID: c90b9560-bf6c-de11-be94-00142212c4b1
		Revision: 324330
		Node Kind: directory
		Schedule: normal
		Last Changed Author: cataphract
		Last Changed Rev: 324327
		Last Changed Date: 2012-03-18 08:07:20 -0700 (Sun, 18 Mar 2012)

i've configure to disable static build

	echo $CFLAGS
		-O2 -march=amdfam10 -mtune=amdfam10
	rm -rf /usr/local/extTEST
	mkdir -p /usr/local/extTEST
	export EXTENSION_DIR='/usr/local/extTEST'
	./configure --prefix=/usr/local/php5 \
	--enable-shared=yes --enable-static=no --enable-session=shared

but after,

	make -j20
	make install
		Installing shared extensions:     /usr/local/extTEST/
		...

BOTH the *.so & *.a ext's are _deployed_ to the extenstion-dir install target.

	ls -al /usr/local/extTEST
		total 124K
		drwxr-xr-x+  2 root root 4.0K Mar 18 09:20 ./
		drwxrwxr-x+ 36 root root 4.0K Mar 18 09:19 ../
		-rwxr-xr-x+  1 root root 105K Mar 18 09:20 session.a*
		-rwxr-xr-x+  1 root root 7.7K Mar 18 09:20 session.so*

this holds true for any individual, or set of, extension(s) specified.

iiuc from chat in ##php, the *.a's _are_ built, and the target *.so's are 
derived from them, but the deployment should only be of the *.so's, in this 
case.

checking the Makefile,

	grep ^"CFLAGS =" Makefile
		CFLAGS = $(CFLAGS_CLEAN) -prefer-non-pic -static

that "-static" flag, apparently installed by libtool (?), is unexpected.

is this a bug, or is there an additional config flag/setting needed to end-up 
with just the *.so's deployed?


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-03-31 02:12 UTC] yohgaki@php.net
-Status: Open +Status: Feedback
 [2012-03-31 02:12 UTC] yohgaki@php.net
Please try using this snapshot:

  http://snaps.php.net/php5.4-latest.tar.gz
 
For Windows:

  http://windows.php.net/snapshots/


 [2013-02-18 00:35 UTC] php-bugs at lists dot php dot net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Dec 08 01:03:35 2021 UTC