php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #61425 amqp-1.0.1 or 1.0.0 won't make.
Submitted: 2012-03-17 06:13 UTC Modified: 2012-08-26 02:54 UTC
From: info at eeasoftware dot com Assigned:
Status: Not a bug Package: amqp (PECL)
PHP Version: 5.4.0 OS: Centos 6.2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: info at eeasoftware dot com
New email:
PHP Version: OS:

 

 [2012-03-17 06:13 UTC] info at eeasoftware dot com
Description:
------------
When I attempt to install the amqp package I get "undeclared function" errors.  It 
happened at first 

Test script:
---------------
pecl install amqp-1.0.1 (or pecl install amqp-1.0.0 both have same result)

Expected result:
----------------
Package installs

Actual result:
--------------
downloading amqp-1.0.1.tgz ...
Starting to download amqp-1.0.1.tgz (28,913 bytes)
.........done: 28,913 bytes
13 source files, building
running: phpize
Configuring for:
PHP Api Version:         20100412
Zend Module Api No:      20100525
Zend Extension Api No:   220100525
building in /tmp/pear/temp/pear-build-rootM8WKLP/amqp-1.0.1
running: /tmp/pear/temp/amqp/configure
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for a sed that does not truncate output... /bin/sed
checking for cc... cc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether cc accepts -g... yes
checking for cc option to accept ISO C89... none needed
checking how to run the C preprocessor... cc -E
checking for icc... no
checking for suncc... no
checking whether cc understands -c and -o together... yes
checking for system library directory... lib
checking if compiler supports -R... no
checking if compiler supports -Wl,-rpath,... yes
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking target system type... x86_64-unknown-linux-gnu
checking for PHP prefix... /usr/local
checking for PHP includes... -I/usr/local/include/php -
I/usr/local/include/php/main -I/usr/local/include/php/TSRM -
I/usr/local/include/php/Zend -I/usr/local/include/php/ext -
I/usr/local/include/php/ext/date/lib
checking for PHP extension directory... /usr/local/lib/php/extensions/no-debug-
non-zts-20100525
checking for PHP installed headers prefix... /usr/local/include/php
checking if debug is enabled... no
checking if zts is enabled... no
checking for re2c... no
configure: WARNING: You will need re2c 0.13.4 or later if you want to regenerate 
PHP parsers.
checking for gawk... gawk
checking for amqp support... yes, shared
checking for amqp... yes, shared
yes
checking for amqp files in default path... found in /usr/local
checking for ld used by cc... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for /usr/bin/ld option to reload object files... -r
checking for BSD-compatible nm... /usr/bin/nm -B
checking whether ln -s works... yes
checking how to recognize dependent libraries... pass_all
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking dlfcn.h usability... yes
checking dlfcn.h presence... yes
checking for dlfcn.h... yes
checking the maximum length of command line arguments... 1966080
checking command to parse /usr/bin/nm -B output from cc object... ok
checking for objdir... .libs
checking for ar... ar
checking for ranlib... ranlib
checking for strip... strip
checking if cc supports -fno-rtti -fno-exceptions... no
checking for cc option to produce PIC... -fPIC
checking if cc PIC flag -fPIC works... yes
checking if cc static flag -static works... no
checking if cc supports -c -o file.o... yes
checking whether the cc linker (/usr/bin/ld -m elf_x86_64) supports shared 
libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... no

creating libtool
appending configuration tag "CXX" to libtool
configure: creating ./config.status
config.status: creating config.h
running: make
/bin/sh /tmp/pear/temp/pear-build-rootM8WKLP/amqp-1.0.1/libtool --mode=compile 
cc  -I. -I/tmp/pear/temp/amqp -DPHP_ATOM_INC -I/tmp/pear/temp/pear-build-
rootM8WKLP/amqp-1.0.1/include -I/tmp/pear/temp/pear-build-rootM8WKLP/amqp-
1.0.1/main -I/tmp/pear/temp/amqp -I/usr/local/include/php -
I/usr/local/include/php/main -I/usr/local/include/php/TSRM -
I/usr/local/include/php/Zend -I/usr/local/include/php/ext -
I/usr/local/include/php/ext/date/lib -I/usr/local/include  -DHAVE_CONFIG_H  -g -
O2   -c /tmp/pear/temp/amqp/amqp.c -o amqp.lo
mkdir .libs
 cc -I. -I/tmp/pear/temp/amqp -DPHP_ATOM_INC -I/tmp/pear/temp/pear-build-
rootM8WKLP/amqp-1.0.1/include -I/tmp/pear/temp/pear-build-rootM8WKLP/amqp-
1.0.1/main -I/tmp/pear/temp/amqp -I/usr/local/include/php -
I/usr/local/include/php/main -I/usr/local/include/php/TSRM -
I/usr/local/include/php/Zend -I/usr/local/include/php/ext -
I/usr/local/include/php/ext/date/lib -I/usr/local/include -DHAVE_CONFIG_H -g -O2 
-c /tmp/pear/temp/amqp/amqp.c  -fPIC -DPIC -o .libs/amqp.o
/bin/sh /tmp/pear/temp/pear-build-rootM8WKLP/amqp-1.0.1/libtool --mode=compile 
cc  -I. -I/tmp/pear/temp/amqp -DPHP_ATOM_INC -I/tmp/pear/temp/pear-build-
rootM8WKLP/amqp-1.0.1/include -I/tmp/pear/temp/pear-build-rootM8WKLP/amqp-
1.0.1/main -I/tmp/pear/temp/amqp -I/usr/local/include/php -
I/usr/local/include/php/main -I/usr/local/include/php/TSRM -
I/usr/local/include/php/Zend -I/usr/local/include/php/ext -
I/usr/local/include/php/ext/date/lib -I/usr/local/include  -DHAVE_CONFIG_H  -g -
O2   -c /tmp/pear/temp/amqp/amqp_exchange.c -o amqp_exchange.lo
 cc -I. -I/tmp/pear/temp/amqp -DPHP_ATOM_INC -I/tmp/pear/temp/pear-build-
rootM8WKLP/amqp-1.0.1/include -I/tmp/pear/temp/pear-build-rootM8WKLP/amqp-
1.0.1/main -I/tmp/pear/temp/amqp -I/usr/local/include/php -
I/usr/local/include/php/main -I/usr/local/include/php/TSRM -
I/usr/local/include/php/Zend -I/usr/local/include/php/ext -
I/usr/local/include/php/ext/date/lib -I/usr/local/include -DHAVE_CONFIG_H -g -O2 
-c /tmp/pear/temp/amqp/amqp_exchange.c  -fPIC -DPIC -o .libs/amqp_exchange.o
/tmp/pear/temp/amqp/amqp_exchange.c: In function âzim_amqp_exchange_class_bindâ:
/tmp/pear/temp/amqp/amqp_exchange.c:839: error: âamqp_exchange_bind_tâ 
undeclared (first use in this function)
/tmp/pear/temp/amqp/amqp_exchange.c:839: error: (Each undeclared identifier is 
reported only once
/tmp/pear/temp/amqp/amqp_exchange.c:839: error: for each function it appears 
in.)
/tmp/pear/temp/amqp/amqp_exchange.c:839: error: expected â;â before âsâ
/tmp/pear/temp/amqp/amqp_exchange.c:840: error: âsâ undeclared (first use in 
this function)
/tmp/pear/temp/amqp/amqp_exchange.c:851: error: âAMQP_EXCHANGE_BIND_OK_METHODâ 
undeclared (first use in this function)
/tmp/pear/temp/amqp/amqp_exchange.c:855: error: âAMQP_EXCHANGE_BIND_METHODâ 
undeclared (first use in this function)
make: *** [amqp_exchange.lo] Error 1
ERROR: `make' failed


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-08-26 02:54 UTC] pdezwart@php.net
-Status: Open +Status: Not a bug
 [2012-08-26 02:54 UTC] pdezwart@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately you are not using a current version of PHP -- 
the problem might already be fixed. Please download a new
PHP version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.

I have no idea how this could happen. It looks like the code was mangled or the 
compiler is unsupported.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Nov 30 01:01:22 2020 UTC