php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #61407 Directive no longer available in PHP
Submitted: 2012-03-15 18:53 UTC Modified: 2012-03-16 01:15 UTC
From: spamik at yum dot pl Assigned:
Status: Not a bug Package: *General Issues
PHP Version: 5.4.0 OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: spamik at yum dot pl
New email:
PHP Version: OS:

 

 [2012-03-15 18:53 UTC] spamik at yum dot pl
Description:
------------
./php-cgi

<b>Fatal error</b>: Directive 'allow_call_time_pass_reference' is no longer 
available in PHP in <b>Unknown</b> on line <b>0</b><br />

<b>Fatal error</b>: Directive 'magic_quotes_gpc' is no longer available in PHP in 
<b>Unknown</b> on line <b>0</b><br />

1) It should return Content-type header before those errors. Without it webserver 
wont display error but instead it will generate 500 error
2) It is stupid to throw fatal error on that. Same php.ini are used with multiple 
php versions commonly. It should be warrning not fatal error. I get that you are 
trying to show programers that magic quotes are finished but still it is bad 
decision on fatal error.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-03-16 01:15 UTC] aharvey@php.net
-Status: Open +Status: Not a bug
 [2012-03-16 01:15 UTC] aharvey@php.net
1. Startup errors are generated before headers can be sent. Sorry. Disable 
display_startup_errors if it's a major problem.

2. This really does need to be a fatal error: there are serious security 
implications for developers still relying on magic quotes, and for users with 
display_startup_errors turned off, silently allowing a normal-seeming startup is 
the worst thing we could do.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun Feb 25 09:01:26 2024 UTC