php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #61372 undefined symbol: Z_ADDREF_P - possibly wrong dependency?
Submitted: 2012-03-13 12:24 UTC Modified: 2012-04-02 10:29 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: schletz at zfg-dortmund dot de Assigned: mike (profile)
Status: Closed Package: pecl_http (PECL)
PHP Version: Irrelevant OS: Debian Lenny
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: schletz at zfg-dortmund dot de
New email:
PHP Version: OS:

 

 [2012-03-13 12:24 UTC] schletz at zfg-dortmund dot de
Description:
------------
(PHP version marked irrelevant to make this bug report work, though version probably matters)

pecl_http 1.7.2 and later don't work on my Debian Lenny (PHP 5.2.6.dfsg.1-1+lenny16) system. I get this in my log file whenever I try to use the package:

symbol lookup error: /usr/lib/php5/20060613+lfs/http.so: undefined symbol: Z_ADDREF_P

Reverting to 1.7.1 helps.

I know that the system is a bit outdated, and upgrading might help. However, PHP 4.3 or later is listed as a dependency for pecl_http, so this is either a bug or the dependency should be changed to a more recent PHP version.

Test script:
---------------
HttpResponse::setContentType('image/jpeg');                                                                          
HttpResponse::setContentDisposition ("name.jpg", true);                                                              
if ($someCondition) {
    HttpResponse::capture();
    imageJpeg($someStuff)
} else {
    HttpResponse::setData($someStuff);
}
HttpResponse::send();


Expected result:
----------------
Should output some data

Actual result:
--------------
No output and log message above

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-04-02 09:42 UTC] mike@php.net
Automatic comment from SVN on behalf of mike
Revision: http://svn.php.net/viewvc/?view=revision&revision=324706
Log: fix bug #61372 (undefined symbol: Z_ADDREF_P - possibly wrong dependency?)
 [2012-04-02 10:29 UTC] mike@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: mike
 [2012-04-02 10:29 UTC] mike@php.net
Fixed in 1.7.4.

Thank you.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sun Aug 14 19:05:46 2022 UTC