|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #61351 Shoud requires PHP > 5.2.0
Submitted: 2012-03-11 17:44 UTC Modified: 2012-07-18 09:14 UTC
From: Assigned: pdezwart (profile)
Status: Closed Package: amqp (PECL)
PHP Version: 5.4.0 OS: GNU/Linux (Fedora 16)
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
Solve the problem:
7 + 28 = ?
Subscribe to this entry?

 [2012-03-11 17:44 UTC]

According to package.xml and to, this package requires PHP >= 5.0.0

There is call to zend_fcall_info_args function which is a PHP 5.2.0 new function

Except if you want to be really compatible with php < 5.2.0, I think a simple documentation update should be enough.


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2012-03-23 06:09 UTC]
-Assigned To: +Assigned To: pdezwart
 [2012-03-23 06:09 UTC]
Assigning to Pieter, as he may want to update the source... which contains a 
single call to zend_fcall_info_args() so maybe it'd be worth it.
 [2012-07-18 09:14 UTC]
Thank you for your bug report. This issue has already been fixed
in the latest released version of PHP, which you can download at

Fixed in 1.0.4. Thanks for the help!
 [2012-07-18 09:14 UTC]
-Status: Assigned +Status: Closed
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Sep 18 01:03:38 2021 UTC