php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #61351 Shoud requires PHP > 5.2.0
Submitted: 2012-03-11 17:44 UTC Modified: 2012-07-18 09:14 UTC
From: remi@php.net Assigned: pdezwart (profile)
Status: Closed Package: amqp (PECL)
PHP Version: 5.4.0 OS: GNU/Linux (Fedora 16)
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: remi@php.net
New email:
PHP Version: OS:

 

 [2012-03-11 17:44 UTC] remi@php.net
Description:
------------
Hi

According to package.xml and to http://pecl.php.net/package/amqp, this package requires PHP >= 5.0.0

There is call to zend_fcall_info_args function which is a PHP 5.2.0 new function

Except if you want to be really compatible with php < 5.2.0, I think a simple documentation update should be enough.



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-03-23 06:09 UTC] philip@php.net
-Assigned To: +Assigned To: pdezwart
 [2012-03-23 06:09 UTC] philip@php.net
Assigning to Pieter, as he may want to update the source... which contains a 
single call to zend_fcall_info_args() so maybe it'd be worth it.
 [2012-07-18 09:14 UTC] pdezwart@php.net
Thank you for your bug report. This issue has already been fixed
in the latest released version of PHP, which you can download at 
http://www.php.net/downloads.php

Fixed in 1.0.4. Thanks for the help!
 [2012-07-18 09:14 UTC] pdezwart@php.net
-Status: Assigned +Status: Closed
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Sep 28 20:03:36 2021 UTC