php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #61348 php 5.4 exec fails @ igbinary "undefined symbol: ps_globals"
Submitted: 2012-03-11 06:13 UTC Modified: 2012-03-11 17:42 UTC
From: locuse at mm dot st Assigned:
Status: Not a bug Package: igbinary (PECL)
PHP Version: 5.4SVN-2012-03-11 (SVN) OS: linux x86_64
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: locuse at mm dot st
New email:
PHP Version: OS:

 

 [2012-03-11 06:13 UTC] locuse at mm dot st
Description:
------------
with a php v54 build from svn sources,

	URL: https://svn.php.net/repository/php/php-src/branches/PHP_5_4
	Repository Root: https://svn.php.net/repository
	Repository UUID: c90b9560-bf6c-de11-be94-00142212c4b1
	Revision: 324092

	php -v
		PHP 5.4.1RC1-dev (cli) (built: Mar 10 2012 20:21:53)
		Copyright (c) 1997-2012 The PHP Group
		Zend Engine v2.4.0, Copyright (c) 1998-2012 Zend Technologies
		    with Xdebug v2.2.0-dev, Copyright (c) 2002-2012, by Derick Rethans

building igbinary from source

	git clone https://github.com/igbinary/igbinary.git
	cd igbinary
	phpize
	./configure --prefix=/usr/local --enable-igbinary
	make
	make install

@ php exec,

	php -m | grep igb
		PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/local/php5/lib64/extensions/no-debug-non-zts-20100525/igbinary.so' - /usr/local/php5/lib64/extensions/no-debug-non-zts-20100525/igbinary.so: undefined symbol: ps_globals in Unknown on line 0


Test script:
---------------
make test

results below

Actual result:
--------------
testing,

	make test
		PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/local/src/igbinary/modules/igbinary.so' - /usr/local/src/igbinary/modules/igbinary.so: undefined symbol: ps_globals in Unknown on line 0
			...
		=====================================================================
		TEST RESULT SUMMARY
		---------------------------------------------------------------------
		Exts skipped    :    0
		Exts tested     :   12
		---------------------------------------------------------------------

		Number of tests :   44                29
		Tests skipped   :   15 ( 34.1%) --------
		Tests warned    :    0 (  0.0%) (  0.0%)
		Tests failed    :   29 ( 65.9%) (100.0%)
		Expected fail   :    0 (  0.0%) (  0.0%)
		Tests passed    :    0 (  0.0%) (  0.0%)
		---------------------------------------------------------------------
		Time taken      :    1 seconds
		=====================================================================

		=====================================================================
		FAILED TEST SUMMARY
		---------------------------------------------------------------------
		Check for null serialisation [tests/igbinary_002.phpt]
		Check for bool serialisation [tests/igbinary_003.phpt]
		Check for integer serialisation [tests/igbinary_004.phpt]
		Check for double serialisation [tests/igbinary_005.phpt]
		Check for simple string serialization [tests/igbinary_006.phpt]
		Check for simple array serialization [tests/igbinary_007.phpt]
		Check for array+string serialization [tests/igbinary_008.phpt]
		Array test [tests/igbinary_010.phpt]
		Object test [tests/igbinary_012.phpt]
		Object-Array test [tests/igbinary_013.phpt]
		Object-Reference test [tests/igbinary_014.phpt]
		Check for serialization handler [tests/igbinary_015.phpt]
		Check for serialization handler, ini-directive [tests/igbinary_015b.phpt]
		Object test, __sleep [tests/igbinary_016.phpt]
		Object test, __wakeup [tests/igbinary_017.phpt]
		Object test, __sleep error cases [tests/igbinary_018.phpt]
		Object test, __autoload [tests/igbinary_019.phpt]
		Object test, incomplete class [tests/igbinary_020.phpt]
		Object Serializable interface [tests/igbinary_021.phpt]
		Object test, unserialize_callback_func [tests/igbinary_022.phpt]
		Recursive objects [tests/igbinary_024.phpt]
		Object test, array of objects with __sleep [tests/igbinary_025.phpt]
		Check for serialization handler [tests/igbinary_027.phpt]
		Serialize object into session, full set [tests/igbinary_028.phpt]
		Object Serializable interface throws exceptions [tests/igbinary_031.phpt]
		b0rked random data test [tests/igbinary_040.phpt]
		Check for double NaN, Inf, -Inf, 0, and -0. IEEE 754 doubles [tests/igbinary_041.phpt]
		Check for double extremes [tests/igbinary_044.phpt]
		Unserialize backwards compatible with v1. [tests/igbinary_unserialize_v1_compatible.phpt]
		=====================================================================



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-03-11 17:39 UTC] locuse at mm dot st
easily solved.

simply ensure session.so loads before igbinary.so,

  cat php5/conf.d/igbinary.ini
    extension = session.so
    extension = igbinary.so
 [2012-03-11 17:39 UTC] locuse at mm dot st
-Status: Open +Status: Closed
 [2012-03-11 17:39 UTC] locuse at mm dot st
invalid
 [2012-03-11 17:42 UTC] cataphract@php.net
-Status: Closed +Status: Not a bug
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Wed Sep 18 18:01:44 2019 UTC