php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #61289 Error compiling/installing memcache extension in 5.4.0
Submitted: 2012-03-05 15:31 UTC Modified: 2012-04-11 02:13 UTC
Votes:5
Avg. Score:5.0 ± 0.0
Reproduced:5 of 5 (100.0%)
Same Version:5 (100.0%)
Same OS:0 (0.0%)
From: tomas at rijndael-project dot com Assigned: hradtke (profile)
Status: Duplicate Package: memcache (PECL)
PHP Version: 5.4.0 OS: GNU/Linux 2.6.32 (Ubuntu) 32bits
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: tomas at rijndael-project dot com
New email:
PHP Version: OS:

 

 [2012-03-05 15:31 UTC] tomas at rijndael-project dot com
Description:
------------
Hi!

I'm trying to compile manually and install via PECL the "memcache" extension in 
PHP 5.4.0, but I get the following error while try to "make".
I'm using memcache 3.0.6 (beta extension).
http://pecl.php.net/package/memcache

The complete output:
downloading memcache-2.2.6.tgz ...
Starting to download memcache-2.2.6.tgz (35,957 bytes)
..........done: 35,957 bytes
11 source files, building
WARNING: php_bin /opt/XWDS/platform/php/bin/php appears to have a suffix 
/bin/php, but config variable php_suffix does not match
running: phpize
Configuring for:
PHP Api Version:         20100412
Zend Module Api No:      20100525
Zend Extension Api No:   220100525
Enable memcache session handler support? [yes] : no
building in /tmp/pear/temp/pear-build-rootSE2fmA/memcache-2.2.6
running: /tmp/pear/temp/memcache/configure --enable-memcache-session=no
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for a sed that does not truncate output... /bin/sed
checking for cc... cc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether cc accepts -g... yes
checking for cc option to accept ISO C89... none needed
checking how to run the C preprocessor... cc -E
checking for icc... no
checking for suncc... no
checking whether cc understands -c and -o together... yes
checking for system library directory... lib
checking if compiler supports -R... no
checking if compiler supports -Wl,-rpath,... yes
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu
checking for PHP prefix... /opt/XWDS/platform/php
checking for PHP includes... -I/opt/XWDS/platform/php/include/php -
I/opt/XWDS/platform/php/include/php/main -
I/opt/XWDS/platform/php/include/php/TSRM -
I/opt/XWDS/platform/php/include/php/Zend -
I/opt/XWDS/platform/php/include/php/ext -
I/opt/XWDS/platform/php/include/php/ext/date/lib
checking for PHP extension directory... 
/opt/XWDS/platform/php/lib/php/extensions
checking for PHP installed headers prefix... /opt/XWDS/platform/php/include/php
checking if debug is enabled... no
checking if zts is enabled... no
checking for re2c... no
configure: WARNING: You will need re2c 0.13.4 or later if you want to regenerate 
PHP parsers.
checking for gawk... no
checking for nawk... nawk
checking if nawk is broken... no
checking whether to enable memcache support... yes, shared
checking whether to enable memcache session handler support... no
checking for the location of ZLIB... no
checking for the location of zlib... /usr
checking for memcache session support... disabled
checking for ld used by cc... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for /usr/bin/ld option to reload object files... -r
checking for BSD-compatible nm... /usr/bin/nm -B
checking whether ln -s works... yes
checking how to recognize dependent libraries... pass_all
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking dlfcn.h usability... yes
checking dlfcn.h presence... yes
checking for dlfcn.h... yes
checking the maximum length of command line arguments... 1572864
checking command to parse /usr/bin/nm -B output from cc object... ok
checking for objdir... .libs
checking for ar... ar
checking for ranlib... ranlib
checking for strip... strip
checking if cc supports -fno-rtti -fno-exceptions... no
checking for cc option to produce PIC... -fPIC
checking if cc PIC flag -fPIC works... yes
checking if cc static flag -static works... yes
checking if cc supports -c -o file.o... yes
checking whether the cc linker (/usr/bin/ld) supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... no

creating libtool
appending configuration tag "CXX" to libtool
configure: creating ./config.status
config.status: creating config.h
running: make
/bin/bash /tmp/pear/temp/pear-build-rootSE2fmA/memcache-2.2.6/libtool --
mode=compile cc  -I. -I/tmp/pear/temp/memcache -DPHP_ATOM_INC -
I/tmp/pear/temp/pear-build-rootSE2fmA/memcache-2.2.6/include -
I/tmp/pear/temp/pear-build-rootSE2fmA/memcache-2.2.6/main -
I/tmp/pear/temp/memcache -I/opt/XWDS/platform/php/include/php -
I/opt/XWDS/platform/php/include/php/main -
I/opt/XWDS/platform/php/include/php/TSRM -
I/opt/XWDS/platform/php/include/php/Zend -
I/opt/XWDS/platform/php/include/php/ext -
I/opt/XWDS/platform/php/include/php/ext/date/lib  -DHAVE_CONFIG_H  -g -O2   -c 
/tmp/pear/temp/memcache/memcache.c -o memcache.lo
mkdir .libs
 cc -I. -I/tmp/pear/temp/memcache -DPHP_ATOM_INC -I/tmp/pear/temp/pear-build-
rootSE2fmA/memcache-2.2.6/include -I/tmp/pear/temp/pear-build-
rootSE2fmA/memcache-2.2.6/main -I/tmp/pear/temp/memcache -
I/opt/XWDS/platform/php/include/php -I/opt/XWDS/platform/php/include/php/main -
I/opt/XWDS/platform/php/include/php/TSRM -
I/opt/XWDS/platform/php/include/php/Zend -
I/opt/XWDS/platform/php/include/php/ext -
I/opt/XWDS/platform/php/include/php/ext/date/lib -DHAVE_CONFIG_H -g -O2 -c 
/tmp/pear/temp/memcache/memcache.c  -fPIC -DPIC -o .libs/memcache.o
In file included from /tmp/pear/temp/memcache/memcache.c:42:
/tmp/pear/temp/memcache/php_memcache.h:159:1: warning: "IS_CALLABLE" redefined
In file included from /opt/XWDS/platform/php/include/php/main/php.h:34,
                 from /tmp/pear/temp/memcache/memcache.c:26:
/opt/XWDS/platform/php/include/php/Zend/zend.h:576:1: warning: this is the 
location of the previous definition
/tmp/pear/temp/memcache/memcache.c: In function âphp_mmc_connectâ:
/tmp/pear/temp/memcache/memcache.c:1970: error: too few arguments to function 
âzend_list_insertâ
/tmp/pear/temp/memcache/memcache.c:1987: error: too few arguments to function 
âzend_list_insertâ
/tmp/pear/temp/memcache/memcache.c: In function âzif_memcache_add_serverâ:
/tmp/pear/temp/memcache/memcache.c:2077: error: too few arguments to function 
âzend_list_insertâ
/tmp/pear/temp/memcache/memcache.c: In function âmmc_find_persistentâ:
/tmp/pear/temp/memcache/memcache.c:2232: error: too few arguments to function 
âzend_list_insertâ
/tmp/pear/temp/memcache/memcache.c:2250: error: too few arguments to function 
âzend_list_insertâ
make: *** [memcache.lo] Error 1
ERROR: `make' failed

Thanks in advanced.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-03-09 10:45 UTC] info at tvdw dot eu
I had the same issue. However, it is already fixed on the SVN trunk.

PS: that's 2.2.6 you're compiling
 [2012-03-10 18:12 UTC] Sergiy dot Borodych at gmail dot com
I have a same problem
https://bugs.gentoo.org/show_bug.cgi?id=407441
 [2012-03-15 13:28 UTC] jdmls at yahoo dot com
I have almost the same problem...
                php 5.4.0 + memcache 3.0.6 = compiles fine.
apache 2.2.22 + php 5.4.0 + memcache 3.0.6 = compiles fine.
apache 2.4.1  + php 5.4.0 + memcache 3.0.6 = does not compile.

If I compare the memcache compilation with and without apache 2.4.1, the 
output is identical up to the (with apache) error:
memcache.c: In function ‘mmc_find_persistent’:
memcache.c:721: error: too few arguments to function ‘zend_list_insert’
memcache.c:738: error: too few arguments to function ‘zend_list_insert’
memcache.c: In function ‘php_mmc_pool_addserver’:
memcache.c:778: error: too few arguments to function ‘zend_list_insert’
memcache.c: In function ‘php_mmc_connect’:
memcache.c:839: error: too few arguments to function ‘zend_list_insert’
make: *** [memcache.lo] Error 1

Not sure how the presence of a certain version of apache leads to that error...

BTW, FYI, when it compiles, I also get:
php_memcache.h:75:1: warning: "IS_CALLABLE" redefined
/php-5.4.0/include/php/Zend/zend.h:#define IS_CALLABLE    10
memcache-3.0.6/php_memcache.h:#   define IS_CALLABLE(cb_zv, flags, cb_sp) zend_is_callable((cb_zv), (flags), (cb_sp) TSRMLS_CC)
 [2012-03-28 18:49 UTC] sixd@php.net
-Assigned To: +Assigned To: hradtke
 [2012-03-28 18:49 UTC] sixd@php.net
This is similar to bug #61544
 [2012-04-11 02:13 UTC] aharvey@php.net
-Status: Assigned +Status: Duplicate
 [2012-04-11 02:13 UTC] aharvey@php.net
Duplicate of bug #61544.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun May 16 11:01:29 2021 UTC