php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #61260 INCLUDE_OR_EVAL op2
Submitted: 2012-03-03 05:47 UTC Modified: 2017-04-01 21:16 UTC
Votes:2
Avg. Score:4.0 ± 1.0
Reproduced:2 of 2 (100.0%)
Same Version:1 (50.0%)
Same OS:1 (50.0%)
From: mat999 at gmail dot com Assigned:
Status: Wont fix Package: parsekit (PECL)
PHP Version: 5.3.10 OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: mat999 at gmail dot com
New email:
PHP Version: OS:

 

 [2012-03-03 05:47 UTC] mat999 at gmail dot com
Description:
------------
No differentiation between include and eval calls, op2 is ignored.

Test script:
---------------
include("test.php");
eval("abc");
include("test.php");
eval("abc");

Expected result:
----------------
op2 0 or 1

Actual result:
--------------
op2 IS_UNUSED

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-04-01 21:16 UTC] tpunt@php.net
-Status: Open +Status: Wont fix
 [2017-04-01 21:16 UTC] tpunt@php.net
Due to this extension not seeing any activity since 2009, this issue will not be fixed. We are therefore closing this now.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun May 26 07:01:26 2019 UTC