php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #61248 ext/mysql and ext/pdo_mysql
Submitted: 2012-03-02 15:38 UTC Modified: 2012-03-05 00:42 UTC
From: iamhiddensomewhere at gmail dot com Assigned:
Status: Not a bug Package: MySQL related
PHP Version: 5.4.0 OS: Linux 2.6.32-5-amd64
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: iamhiddensomewhere at gmail dot com
New email:
PHP Version: OS:

 

 [2012-03-02 15:38 UTC] iamhiddensomewhere at gmail dot com
Description:
------------
* cd to ext/pdo_mysql or ext/mysql

* phpize && ./configure && make && make install

ext/pdo_mysql fails at make with the following output: 
http://pastebin.com/ibYSpMqs


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-03-02 16:05 UTC] iamhiddensomewhere at gmail dot com
-Summary: ext/mysql and ext/pdo_mysql +Summary: ext/mysql and ext/pdo_mysql don't compile
 [2012-03-02 16:05 UTC] iamhiddensomewhere at gmail dot com
Fixing summary
 [2012-03-02 16:07 UTC] johannes@php.net
-Summary: ext/mysql and ext/pdo_mysql don't compile +Summary: ext/mysql and ext/pdo_mysql -Status: Open +Status: Not a bug
 [2012-03-02 16:07 UTC] johannes@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

In 5.4 the default is to use mysqlnd. When building completely stand-alone you first have to install mysqlnd so that the headers and stuff are in place and then youcan configure the standalone extension. Alternatively, and not suggested, you can do --with-pdo-mysql=PATH to use libmysql.
 [2012-03-02 16:41 UTC] iamhiddensomewhere at gmail dot com
I'm not entirely certain how to determine whether mysqlnd (and/or the mysqlnd 
headers) is installed, or how to install it.

Is it possible to install ext/pdo_mysql -- or ext/mysqli -- *only* at compile 
time?
 [2012-03-02 16:43 UTC] iamhiddensomewhere at gmail dot com
(Forgive me for the double post)

My previous question was meant to be asking whether it is possible to install 
ext/pdo_mysql (or ext/mysqli) *after* compiling php-5.4.0.
 [2012-03-05 00:42 UTC] johannes@php.net
In general doing stand-alone builds of bundled extensions using phpize is an edge-case from support perspective as bundled extensions might make specific assumptions.

I didn't test it, but what might work is to build and install mysqlnd first:
cd ext/mysqlnd && phpize && ./configure --enable-mysqlnd=shared && make install
and then install ext/mysql, mysqli and pdo_mysql

or (less suggested) not to use mysqlnd but an installed libmysql, by using --with-mysql=PATH (where PATH is a proper path to libmysql, probably /usr, same for the other two extensions)

On mysqlnd vs. libmysql see http://php.net/mysqlinfo.library.choosing
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu May 19 19:04:05 2022 UTC