php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #61195 Symbols referenced but definition not found
Submitted: 2012-02-27 15:57 UTC Modified: 2012-02-27 16:13 UTC
From: wayne dot krauth at insuranceautomationgroup dot co Assigned:
Status: Not a bug Package: Apache2 related
PHP Version: 5.3.10 OS: AIX 6.1
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
50 - 39 = ?
Subscribe to this entry?

 
 [2012-02-27 15:57 UTC] wayne dot krauth at insuranceautomationgroup dot co
Description:
------------
After successful configure and make, then adding extension=imagick.so to php.ini, PHP fails to load imagick.so on apache (2.2.21) startup.  The Apache error_log reports the following errors:

PHP Warning:  PHP Startup: Unable to load dynamic library '/opt/freeware/lib/php/modules/imagick.so' - rtld: 0712-001 Symbol executor_globals was referenced\n      from module /opt/freeware/lib/php/modules/imagick.so(), but a runtime definition\n      of the symbol was not found.\nrtld: 0712-001 Symbol core_globals was referenced\n      from module /opt/freeware/lib/php/modules/imagick.so(), but a runtime definition\n      of the symbol was not found.\nrtld: 0712-001 Symbol sqrt was referenced\n      from module /opt/freeware/lib/php/modules/imagick.so(), but a runtime definition\n      of the symbol was not found. in Unknown on line 0


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-02-27 16:12 UTC] johannes@php.net
This means you're mixing thread-safe and non-thread-safe PHP installations. Please ensure to configure the extension using --with-php-config=/path/to/bin/php-config where php-config belongs to the PHP installation you're using lateron.
 [2012-02-27 16:13 UTC] johannes@php.net
-Status: Open +Status: Not a bug
 [2012-02-27 16:13 UTC] johannes@php.net
Setting as "Not a bug", please check with support forums etc.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun Feb 25 09:01:26 2024 UTC