php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #61192 Serializable interface not calling unserialize()
Submitted: 2012-02-27 05:12 UTC Modified: 2012-02-27 09:59 UTC
From: slusarz at curecanti dot org Assigned:
Status: Not a bug Package: *Data Exchange functions
PHP Version: 5.3.10 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: slusarz at curecanti dot org
New email:
PHP Version: OS:

 

 [2012-02-27 05:12 UTC] slusarz at curecanti dot org
Description:
------------
unserialize() in a class implementing Serializable is not called when the serialized object is contained within a container element (e.g. array).

Compare with __wakeup() which IS called in the same environment.

In the test script below, if the class is modified to not extend Serializable, the output is:

Sleep
Wakeup



Test script:
---------------
class Foo implements Serializable {

    public function __sleep() {
        print "Sleep\n";
        return array();
    }

    public function __wakeup() {
        print "Wakeup\n";
    }

    public function serialize() {
        print "Serialize\n";
    }

    public function unserialize($data) {
        print "Unserialize\n";
    }

}

$a = array(
    new Foo()
);

$b = serialize($a);
unserialize($b);

Expected result:
----------------
Serialize
Unserialize

Actual result:
--------------
Serialize

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-02-27 09:59 UTC] mike@php.net
-Status: Open +Status: Not a bug
 [2012-02-27 09:59 UTC] mike@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

You have to return something from Foo::serialize().
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Mon Oct 22 12:01:26 2018 UTC