php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #61154 configure fails with Oracle Instantclient 11.2
Submitted: 2012-02-21 15:04 UTC Modified: 2012-02-23 21:45 UTC
From: wayne dot krauth at insuranceautomationgroup dot co Assigned: sixd (profile)
Status: Duplicate Package: OCI8 related
PHP Version: 5.3.10 OS: aix 6.1
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: wayne dot krauth at insuranceautomationgroup dot co
New email:
PHP Version: OS:

 

 [2012-02-21 15:04 UTC] wayne dot krauth at insuranceautomationgroup dot co
Description:
------------
Trying to build php 6.3.10 on AIX 6.1, and including the oci8 InstantClient 11.2 from Oracle fails at the configure stage.

Configure reports: checking Oracle Instant Client library version compatibility... configure: error: Oracle Instant Client libraries libnnz.so and libclntsh.so not found


I modified the configure script to solve this problem, changing a 1 to a 2 as seen in the before and after lines:

# OCI8_LCS=`ls $OCI8_LCS_BASE.*.1 2> /dev/null | tail -1`  # Oracle 10g, 11g etc

  OCI8_LCS=`ls $OCI8_LCS_BASE.*.2 2> /dev/null | tail -1`  # Oracle 10g, 11g etc


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-02-21 20:18 UTC] sixd@php.net
-Package: *Configuration Issues +Package: OCI8 related -Assigned To: +Assigned To: sixd
 [2012-02-21 22:15 UTC] sixd@php.net
What created libclntsh.so.11.2?  The instantclient-basic-aix.ppc64-11.2.0.3.0.zip 
and instantclient-basic-aix.ppc32-11.2.0.3.0.zip files only contain libclntsh.so

What's your configure line?
 [2012-02-21 22:16 UTC] sixd@php.net
-Status: Assigned +Status: Feedback
 [2012-02-22 16:36 UTC] wayne dot krauth at insuranceautomationgroup dot co
In previous installs using instant client, I found that you need to create a link as follows:
lrwxrwxrwx    1 root     system           12 Feb 14 10:13 libclntsh.so.11.2 -> libclntsh.so


The configure command that I used is:

./configure --cache-file=../config.cache \
--with-gnu-ld \
--prefix=/opt/freeware \
--with-config-file-path=/opt/freeware/etc \
--with-config-file-scan-dir=/opt/freeware/etc/php.d \
--disable-debug \
--enable-shared \
--enable-static \
--without-pear \
--with-gd=/opt/freeware \
--with-openssl=/opt/freeware \
--with-zlib \
--with-bz2 \
--with-curl=/opt/freeware \
--with-t1lib=/opt/freeware \
--with-freetype-dir=/opt/freeware \
--with-jpeg-dir=/opt/freeware \
--with-png-dir=/opt/freeware \
--with-xpm-dir=/opt/freeware \
--with-zlib-dir=/opt/freeware \
--enable-soap \
--enable-bcmath  \
--enable-sockets \
--with-iconv \
--enable-dom \
--enable-json \
--with-pcre-regex=/opt/freeware \
--disable-ftp \
--disable-phar  \
--with-mhash \
--with-mcrypt \
--with-apxs2=/opt/freeware/sbin/apxs \
--with-oci8=instantclient,/opt/instantclient_11_2
 [2012-02-23 21:45 UTC] sixd@php.net
Duplicate of 60901. Let's discuss it there.
 [2012-02-23 21:45 UTC] sixd@php.net
-Status: Feedback +Status: Duplicate
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Dec 08 18:03:33 2021 UTC