php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #61137 missing mysql_stmt_get_result()
Submitted: 2012-02-19 04:48 UTC Modified: 2012-02-19 05:04 UTC
From: yohgaki@php.net Assigned:
Status: Not a bug Package: MySQLi related
PHP Version: 5.3.10 OS: Linux
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: yohgaki@php.net
New email:
PHP Version: OS:

 

 [2012-02-19 04:48 UTC] yohgaki@php.net
Description:
------------
Not researched why this happens, but somehow a function is missing in PHP 5.3.10, 
but not 5.4.

The manual says mysqli_stmt_get_result() is available from PHP 5.3.0, but it is 
missing.

http://jp2.php.net/manual/en/mysqli-stmt.get-result.php

msyqli_stmt::get_result() also seems missing.



Test script:
---------------
[yohgaki@dev php-5.3.10]$ ./configure --with-mysqli && make -j 9
[yohgaki@dev php-5.3.10]$ ./sapi/cli/php -r "print_r(get_defined_functions());" | grep mysqli_stmt_get
            [239] => mysqli_stmt_get_warnings


Expected result:
----------------
This is PHP 5.4 svn result.

[yohgaki@dev php-src-5.4]$ ./sapi/cli/php -r "print_r(get_defined_functions());" 
| grep mysqli_stmt_get
            [246] => mysqli_stmt_get_result
            [247] => mysqli_stmt_get_warnings


Actual result:
--------------
[yohgaki@dev php-5.3.10]$ ./sapi/cli/php -r "print_r(get_defined_functions());" | 
grep mysqli_stmt_get
            [239] => mysqli_stmt_get_warnings

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-02-19 05:04 UTC] rasmus@php.net
The manual also says these functions are only available if you are using the 
mysqlnd client library. Nyiur case you didn't use mysqlnd for your 5.3 build and 
in 5.4 we default to mysqlnd unless you specify otherwise. That's why you are 
seeing the difference.
 [2012-02-19 05:04 UTC] rasmus@php.net
-Status: Open +Status: Not a bug
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Oct 04 03:05:53 2022 UTC