php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #60973 extensions not loaded
Submitted: 2012-02-03 18:24 UTC Modified: 2012-02-03 22:18 UTC
From: bugzilla33 at gmail dot com Assigned:
Status: Duplicate Package: *Configuration Issues
PHP Version: 5.4.0RC6 OS: win 7
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: bugzilla33 at gmail dot com
New email:
PHP Version: OS:

 

 [2012-02-03 18:24 UTC] bugzilla33 at gmail dot com
Description:
------------
0. download http://host0001.webd.pl/bugs/php/bug.7z


1. This is http://www.apachelounge.com/download/binaries/httpd-2.2.21-win32.zip


2. And http://windows.php.net/downloads/qa/php-5.4.0RC7-Win32-VC9-x86.zip


3. httpd.conf modifications

   PHPINIDir c:/php54
   LoadModule php5_module c:/php54/php5apache2_2.dll
   AddType application/x-httpd-php .php


4. php.ini (from php.ini-development) modifications

   extension_dir = "c:\php54\ext"

   extension=php_gd2.dll
   extension=php_intl.dll
   extension=php_mbstring.dll


5. Steps to reproduce

   - use Windows 7 (64-bit ?)
   - upack this to c:\ root
   - run install.bat (install Apache service)
   - run start.bat (start Apache service)
   - type in browser http://127.0.0.1/phpinfo.php

6. Expected result

   - gd loaded
   - intl loaded
   - mbstring loaded

7. Actual result
   - only mbstring loaded


8. Tested on two other machines


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-02-03 20:44 UTC] cataphract@php.net
-Status: Open +Status: Not a bug
 [2012-02-03 20:44 UTC] cataphract@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

Looks simply like the dependencies of those two extensions are not being located 
(e.g. icu*.dll for intl); mbstring works because it has none. Take a look at 
http://msdn.microsoft.com/en-
us/library/windows/desktop/ms682586(v=vs.85).aspx#search_order_for_desktop_applic
ations
 [2012-02-03 20:48 UTC] bugzilla33 at gmail dot com
Maybe, but what about the gd2?
 [2012-02-03 20:51 UTC] bugzilla33 at gmail dot com
If using PHP 5.4 RC4 gd2 is available.
 [2012-02-03 21:28 UTC] cataphract@php.net
I don't know that extension, but you can check its dependencies for instance with 
the "dependency walker" (google it).
 [2012-02-03 22:18 UTC] pajoye@php.net
Do NOT report many times the exact bug or issue you are experiencing. It is 
getting seriously annoying now.
 [2012-02-03 22:18 UTC] pajoye@php.net
-Status: Not a bug +Status: Duplicate
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Thu Nov 15 17:01:26 2018 UTC