php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #60917 pecl_http installation failed caused by Zend API change: default_properties
Submitted: 2012-01-28 13:32 UTC Modified: 2012-02-21 15:20 UTC
From: yos dot asakawa at gmail dot com Assigned: mike (profile)
Status: Closed Package: PECL (PECL)
PHP Version: 5.4.0RC6 OS: CentOS 5.7
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: yos dot asakawa at gmail dot com
New email:
PHP Version: OS:

 

 [2012-01-28 13:32 UTC] yos dot asakawa at gmail dot com
Description:
------------
Installing pecl_http shows below errors.
It seems to be caused by Bug #59731 (Zend API change: default_properties).

# pecl install pecl_http
downloading pecl_http-1.7.1.tgz ...
...

/var/tmp/pecl_http/http_message_object.c:517: error: 'zend_class_entry' has no 
member named 'default_properties'
/var/tmp/pecl_http/http_message_object.c:518: error: 'zend_class_entry' has no 
member named 'default_properties'


Test script:
---------------
# pecl install pecl_http

Expected result:
----------------
No error occurs. Installation finished successfully.

Actual result:
--------------
Installation pecl_http failed.

Patches

http_requestpool_object.patch (last revision 2012-01-28 13:38 UTC by yos dot asakawa at gmail dot com)
http_requestdatashare_object.patch (last revision 2012-01-28 13:38 UTC by yos dot asakawa at gmail dot com)
http_request_object.patch (last revision 2012-01-28 13:37 UTC by yos dot asakawa at gmail dot com)
http_querystring_object.patch (last revision 2012-01-28 13:36 UTC by yos dot asakawa at gmail dot com)
http_inflatestream_object.patch (last revision 2012-01-28 13:35 UTC by yos dot asakawa at gmail dot com)
http_deflatestream_object.patch (last revision 2012-01-28 13:34 UTC by yos dot asakawa at gmail dot com)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-01-28 16:43 UTC] rasmus@php.net
-Status: Open +Status: Assigned -Assigned To: +Assigned To: mike
 [2012-01-30 13:18 UTC] mike@php.net
Thank you very much for the patches, but I guess these wouldn't suffice to make 
pecl_http-v1 build with trunk or PHP_5_4.

Did it succeed for you?  What about the output handlers, etc.?
 [2012-01-30 19:31 UTC] yos dot asakawa at gmail dot com
Hi Mike,
Thanks for comment.
You are right, I finally failed to install because of output handler
problem. And I didn't know that I must use version 2.0 of pecl_http 
with php 5.3.99 and over.

I successfully installed pecl_http 2.0.0_dev4.
But I can't use http_build_url() with an error.
"PHP Fatal error:  Call to undefined function http_build_url()"

Can I use http_build_url() with pecl_http 2.0?
Was my install operations bellow invalid?

===================================================
# wget http://pecl.php.net/get/pecl_http-2.0.0dev4.tgz
# cd pecl_http-2.0.0dev4
# phpize
# ./configure
# make
# make test
# make install

# ls -l /usr/lib64/php/modules/http.so 
-rwxr-xr-x 1 root root 1879562  JAN 31 03:58 /usr/lib64/php/modules/http.so

add extension_dir and extension entry
# diff php.ini php.ini.old 
731d730
< extension_dir = /usr/lib64/php/modules
862d860
< extension=http.so
===================================================

Thanks.
 [2012-02-18 05:21 UTC] rob at affclicks dot com
Just a note to other people visiting this that the current SVN trunk (1.7.2) seems 
to have fixes for this that worked for me, thanks.
Just a question because I couldn't find it elsewhere, I am pretty much just using 
this for the http_build_url function, has this been removed without replacement in 
v2? Going forward I could find/ write a replacement but while it is possible 
better to use this one that is tried and tested.
 [2012-02-21 15:20 UTC] mike@php.net
@rob,

it's functionality has moved into the http\Url class in v2.
 [2012-02-21 15:20 UTC] mike@php.net
This bug has been fixed in SVN.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.

 For Windows:

http://windows.php.net/snapshots/
 
Thank you for the report, and for helping us make PHP better.


 [2012-02-21 15:20 UTC] mike@php.net
-Status: Assigned +Status: Closed
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Jul 04 16:01:27 2020 UTC