php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #60899 don´t compile
Submitted: 2012-01-27 04:57 UTC Modified: 2015-08-11 18:31 UTC
Votes:2
Avg. Score:4.0 ± 1.0
Reproduced:2 of 2 (100.0%)
Same Version:1 (50.0%)
Same OS:0 (0.0%)
From: roberto at spadim dot com dot br Assigned: cmb (profile)
Status: Duplicate Package: perl (PECL)
PHP Version: 5.3.9 OS: linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: roberto at spadim dot com dot br
New email:
PHP Version: OS:

 

 [2012-01-27 04:57 UTC] roberto at spadim dot com dot br
Description:
------------
hi guys php-perl don´t compile on php 5.3.9 at x86-64 computer any help?

i wget the package, tar -zxf it, phpize, ./configure, make and it give a error


/var/abs/local/php-perl/perl-1.0.0/php_perl.c: At top level:
/var/abs/local/php-perl/perl-1.0.0/php_perl.c:1946:3: error: 'PHP_PERL_VERSION' undeclared here (not in a function)


Test script:
---------------
? no script, it´s at compile time of extension

Expected result:
----------------
just compile it, maybe old code didn´t allow php 5.3 api

Actual result:
--------------
no compile :( no extensio :'(

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-01-27 05:04 UTC] aharvey@php.net
-Package: *General Issues +Package: perl
 [2012-02-14 15:08 UTC] brian dot marshall at gsmls dot com
same no compile.
Linux 2.6.32-71.el6.i686 #1 SMP Wed Sep 1 01:26:34 EDT 2010 i686 i686 i386 
GNU/Linux
PHP Version 5.3.10
perl-1.0.0

./configure --with-php-config=/usr/local/php/bin/php-config
make :
/bin/sh /tmp/php-5.3.10/ext/perl/libtool --mode=compile cc  -I. -I/tmp/php-
5.3.10/ext/perl -DPHP_ATOM_INC -I/tmp/php-5.3.10/ext/perl/include -I/tmp/php-
5.3.10/ext/perl/main -I/tmp/php-5.3.10/ext/perl -I/usr/local/php/include/php -
I/usr/local/php/include/php/main -I/usr/local/php/include/php/TSRM -
I/usr/local/php/include/php/Zend -I/usr/local/php/include/php/ext -
I/usr/local/php/include/php/ext/date/lib  -DHAVE_CONFIG_H  -g -O2 -D_REENTRANT -
D_GNU_SOURCE -fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include -
D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I/usr/lib/perl5/CORE  -c /tmp/php-
5.3.10/ext/perl/php_perl.c -o php_perl.lo 
mkdir .libs
 cc -I. -I/tmp/php-5.3.10/ext/perl -DPHP_ATOM_INC -I/tmp/php-
5.3.10/ext/perl/include -I/tmp/php-5.3.10/ext/perl/main -I/tmp/php-
5.3.10/ext/perl -I/usr/local/php/include/php -I/usr/local/php/include/php/main -
I/usr/local/php/include/php/TSRM -I/usr/local/php/include/php/Zend -
I/usr/local/php/include/php/ext -I/usr/local/php/include/php/ext/date/lib -
DHAVE_CONFIG_H -g -O2 -D_REENTRANT -D_GNU_SOURCE -fno-strict-aliasing -pipe -
fstack-protector -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 
-I/usr/lib/perl5/CORE -c /tmp/php-5.3.10/ext/perl/php_perl.c  -fPIC -DPIC -o 
.libs/php_perl.o
/tmp/php-5.3.10/ext/perl/php_perl.c:172: warning: initialization from 
incompatible pointer type
/tmp/php-5.3.10/ext/perl/php_perl.c:173: warning: initialization from 
incompatible pointer type
/tmp/php-5.3.10/ext/perl/php_perl.c:199: warning: initialization from 
incompatible pointer type
/tmp/php-5.3.10/ext/perl/php_perl.c:200: warning: initialization from 
incompatible pointer type
/tmp/php-5.3.10/ext/perl/php_perl.c: In function 'php_perl_zval_to_sv_ref':
/tmp/php-5.3.10/ext/perl/php_perl.c:343: error: 'zval' has no member named 
'is_ref'
/tmp/php-5.3.10/ext/perl/php_perl.c:350: error: 'zval' has no member named 
'is_ref'
/tmp/php-5.3.10/ext/perl/php_perl.c: In function 'php_perl_zval_to_sv_noref':
/tmp/php-5.3.10/ext/perl/php_perl.c:393: error: 'zval' has no member named 
'is_ref'
/tmp/php-5.3.10/ext/perl/php_perl.c:423: error: 'zval' has no member named 
'is_ref'
/tmp/php-5.3.10/ext/perl/php_perl.c: In function 'php_perl_sv_to_zval_ref':
/tmp/php-5.3.10/ext/perl/php_perl.c:483: error: 'zval' has no member named 
'is_ref'
/tmp/php-5.3.10/ext/perl/php_perl.c:485: error: 'zval' has no member named 
'refcount'
/tmp/php-5.3.10/ext/perl/php_perl.c: In function 'php_perl_get':
/tmp/php-5.3.10/ext/perl/php_perl.c:753: error: 'zval' has no member named 
'refcount'
/tmp/php-5.3.10/ext/perl/php_perl.c: In function 'php_perl_read_dimension':
/tmp/php-5.3.10/ext/perl/php_perl.c:827: error: 'zval' has no member named 
'refcount'
/tmp/php-5.3.10/ext/perl/php_perl.c:828: error: 'zval' has no member named 
'is_ref'
/tmp/php-5.3.10/ext/perl/php_perl.c:836: error: 'zval' has no member named 
'refcount'
/tmp/php-5.3.10/ext/perl/php_perl.c: In function 'php_perl_read_property':
/tmp/php-5.3.10/ext/perl/php_perl.c:976: error: 'zval' has no member named 
'refcount'
/tmp/php-5.3.10/ext/perl/php_perl.c:993: error: 'zval' has no member named 
'refcount'
/tmp/php-5.3.10/ext/perl/php_perl.c:1010: error: 'zval' has no member named 
'refcount'
/tmp/php-5.3.10/ext/perl/php_perl.c:1088: error: 'zval' has no member named 
'refcount'
/tmp/php-5.3.10/ext/perl/php_perl.c:1089: error: 'zval' has no member named 
'is_ref'
/tmp/php-5.3.10/ext/perl/php_perl.c:1096: error: 'zval' has no member named 
'refcount'
/tmp/php-5.3.10/ext/perl/php_perl.c: In function 'php_perl_get_iterator':
/tmp/php-5.3.10/ext/perl/php_perl.c:1758: error: 'zval' has no member named 
'refcount'
/tmp/php-5.3.10/ext/perl/php_perl.c: In function 'zm_startup_perl':
/tmp/php-5.3.10/ext/perl/php_perl.c:1779: warning: assignment from incompatible 
pointer type
make: *** [php_perl.lo] Error 1
 [2015-08-11 18:31 UTC] cmb@php.net
-Status: Open +Status: Duplicate -Assigned To: +Assigned To: cmb
 [2015-08-11 18:31 UTC] cmb@php.net
Duplicate of bug #59340.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri Dec 03 08:03:33 2021 UTC