php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #60890 Can not read tgz file through Phar class, but related path works
Submitted: 2012-01-26 12:04 UTC Modified: 2013-03-05 21:11 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:0 (0.0%)
From: cornelius dot howl at gmail dot com Assigned:
Status: Not a bug Package: PHAR related
PHP Version: 5.3.9 OS: Mac OS 10.6
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: cornelius dot howl at gmail dot com
New email:
PHP Version: OS:

 

 [2012-01-26 12:04 UTC] cornelius dot howl at gmail dot com
Description:
------------
Can not read tgz file with realpath, offsetGet works, offsetSet doesnt work.

$p['file'] = 'content';  

will fail.

See: https://gist.github.com/1682446

Test script:
---------------
https://gist.github.com/1682446

Actual result:
--------------
See: https://gist.github.com/1682446

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2013-03-05 21:11 UTC] ralphschindler@php.net
-Status: Open +Status: Not a bug
 [2013-03-05 21:11 UTC] ralphschindler@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

The filename passed to the first parameter of the Phar constructor must contain .phar in the file's extension to be created/opened.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Aug 10 02:01:24 2020 UTC