php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #6089 ociplogon sometimes gives bus error
Submitted: 2000-08-10 21:36 UTC Modified: 2001-12-16 07:24 UTC
From: johnw at cogs dot susx dot ac dot uk Assigned:
Status: Closed Package: OCI8 related
PHP Version: 4.0.1pl2 OS: SunOS 5.7
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: johnw at cogs dot susx dot ac dot uk
New email:
PHP Version: OS:

 

 [2000-08-10 21:36 UTC] johnw at cogs dot susx dot ac dot uk
Oracle version 8.0.4
Apache version 1.3.4
PHP version 4.0.1pl2
PHP options:
--with-apache=../apache_1.3.4 --with-oci8 --with-gd=/local --enable-safe-mode --
enable-track-vars --with-gdbm=/local

ociplogon sometimes leads to a Bus error
problem is intermittent
gdb backtrace follows

Program received signal SIGBUS, Bus error.
0xfef7b798 in kghmkfree ()
(gdb) bt
#0  0xfef7b798 in kghmkfree ()
#1  0xfef7ca04 in kghaddex ()
#2  0xfef7ccb8 in kghgex ()
#3  0xfef7e110 in kghfnd ()
#4  0xfef7ea60 in kghpmalo ()
#5  0xfef7fb1c in kghalp ()
#6  0xfecb2838 in kpuhhalp ()
#7  0xfeebf710 in ttcbur ()
#8  0xfeeb489c in ttcdrv ()
#9  0xfed24fb8 in nioqwa ()
#10 0xfecf302c in upirtrc ()
#11 0xfecf2b64 in upirtr ()
#12 0xfecd9880 in kpugskey ()
#13 0xfecd9de4 in kpu8lgn ()
#14 0xfecd6fd0 in kpuauth ()
#15 0x3a504 in _oci_open_session (server=0x366838, 
    username=0x1f57a0 "cogslib", password=0x1f57e0 "qwop10", persistent=1, 
    exclusive=0) at oci8.c:1922
#16 0x3aee0 in oci_do_connect (ht=2, return_value=0x38ce98, this_ptr=0x0, 
    return_value_used=1, persistent=3565624, exclusive=0) at oci8.c:2266
#17 0x3d858 in php_if_ociplogon (ht=2, return_value=0x38ce98, this_ptr=0x0, 
    return_value_used=1) at oci8.c:3589
#18 0xca7fc in execute ()
#19 0xcaadc in execute ()
#20 0xcaadc in execute ()
#21 0x18560 in php_execute_script (primary_file=0xffbef768) at main.c:1157
#22 0xa4e04 in apache_php_module_main (r=0x237ed0, fd=22, 
    display_source_mode=0) at sapi_apache.c:93
#23 0x15674 in send_php ()
#24 0x156cc in send_parsed_php ()
#25 0xf80f0 in ap_invoke_handler ()
#26 0x113744 in process_request_internal ()
#27 0x1137c8 in ap_process_request ()
---Type <return> to continue, or q <return> to quit---
#28 0x107e20 in child_main ()
#29 0x1080b4 in make_child ()
#30 0x1082cc in startup_children ()
#31 0x108ca8 in standalone_main ()
#32 0x109850 in main ()





Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-08-10 23:26 UTC] thies@php.net
i believe this is fixed in CVS - plz try latest snapshot from snaps.php.net

 [2000-09-03 07:50 UTC] waldschrott@php.net
Closed due to missing user feedback.
 [2000-09-04 07:31 UTC] johnw at cogs dot susx dot ac dot uk
I've downloaded and installed PHP 4.0.2
This bug still occurs.
Let me know if you need any further information.
Please don't class this as fixed - it isn't!
 [2000-11-23 19:08 UTC] sniper@php.net
Have you tried PHP4.0.3pl1 or snapshot from http://snaps.php.net/ ??
If not please do try it out. And you're running quite old Apache. I'd consider
upgrading it. And there have been upgrades to Oracle too since 8.0.4..

--Jani
 [2000-12-30 11:53 UTC] sniper@php.net
No feedback, considered fixed.

--Jani
 [2001-01-08 06:22 UTC] johnw at cogs dot susx dot ac dot uk
I've just upgraded to Apache 1.3.14, PHP 4.0.4

Sadly the bug still occurs!

Same hardware/os.


 [2001-11-25 07:43 UTC] mfischer@php.net
Sorry to bug you once more, can you try with latest RC?

http://www.php.net/~zeev/php-4.1.0RC3.tar.gz

Feedback.
 [2001-12-16 07:24 UTC] sander@php.net
No feedback. Closing.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Sep 26 20:05:53 2022 UTC