php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #60815 load configuration file failure
Submitted: 2012-01-20 03:37 UTC Modified: 2015-06-11 11:15 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: zighouse at hotmail dot com Assigned: cmb (profile)
Status: Wont fix Package: Windows Installer
PHP Version: 5.3.9 OS: windows xp
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: zighouse at hotmail dot com
New email:
PHP Version: OS:

 

 [2012-01-20 03:37 UTC] zighouse at hotmail dot com
Description:
------------
Install php-5.3.9-Win32-VC9-x86.msi on windows with configure to apache2.2 httpd.conf, yield wrong configuration file path. phpinfo() reports "Loaded configuration file" as "(none)".

I have also found the solution to it by change the PHPIniDir value in httpd.conf from "C:\Program Files\PHP\" to "C:\\Program Files\\PHP\\" or "C:/Program Files/PHP/".

It is likely php5.3 does not consider a single '\' as a path seperator but a '/' or '\\' is.

Test script:
---------------
.

Expected result:
----------------
.

Actual result:
--------------
.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-06-11 11:15 UTC] cmb@php.net
-Status: Open +Status: Wont fix -Package: Apache2 related +Package: Windows Installer -Assigned To: +Assigned To: cmb
 [2015-06-11 11:15 UTC] cmb@php.net
This ticket is obsolete, because Microsoft installer binaries
(.msi) are not distributed anymore as of PHP 5.4.0.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Oct 25 20:01:23 2020 UTC