php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #60754 autoloader for extensions :D
Submitted: 2012-01-14 17:33 UTC Modified: 2016-10-14 16:03 UTC
Votes:13
Avg. Score:2.8 ± 1.1
Reproduced:5 of 8 (62.5%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: valentiny510 at yahoo dot es Assigned: cmb (profile)
Status: Closed Package: PHP options/info functions
PHP Version: 5.4.0RC5 OS: windows
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: valentiny510 at yahoo dot es
New email:
PHP Version: OS:

 

 [2012-01-14 17:33 UTC] valentiny510 at yahoo dot es
Description:
------------
Yes ! Why not ? Everybody this days are crazy about autoloaders (spl &co) and they build applications around this ... anyway..

it will be nice to have an autoloader into the php.ini like

autoload_extensions = "On"

and not have the xxx lines with all extensions we want
extension = 1.dll
...
extension = 300.dll

Ok you got the point.. SeeYa


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-10-14 16:03 UTC] cmb@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: cmb
 [2016-10-14 16:03 UTC] cmb@php.net
An extension autoloader would have the same issues as dl() plus
some more. However, dl() has already been removed from most SAPIs
as of PHP 5.3.0 due to stability issues.

So this is very unlikely to be ever implemented.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Apr 14 04:01:24 2021 UTC