php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #60748 mysqlnd doesn't honour --with-mysql-sock
Submitted: 2012-01-13 16:56 UTC Modified: 2012-01-16 21:17 UTC
From: fedora at famillecollet dot com Assigned:
Status: Not a bug Package: MySQL related
PHP Version: 5.4.0RC5 OS: GNU/Linux (Fedora 16)
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: fedora at famillecollet dot com
New email:
PHP Version: OS:

 

 [2012-01-13 16:56 UTC] fedora at famillecollet dot com
Description:
------------
Patch to MySQL socket is harcoded and doesn't honour --with-mysql-sock.

Trivial patch fix this


Patches

mysqlnd-sock.patch (last revision 2012-01-13 17:27 UTC by fedora at famillecollet dot com)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-01-16 21:17 UTC] andrey@php.net
-Status: Open +Status: Bogus
 [2012-01-16 21:17 UTC] andrey@php.net
This setting is on the level above mysqlnd - the extensions mysql, mysqli and pdo_mysql which all use this setting. If they don't then this is a bug in them. Otherwise there will be code duplications because with libmysql the code needs to be in the extensions.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed May 18 09:04:05 2022 UTC