php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #60730 cannot build mysql.so module with --with-mysql=mysqlnd
Submitted: 2012-01-12 15:31 UTC Modified: 2012-01-28 00:21 UTC
Votes:1
Avg. Score:4.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: czachary at wiley dot com Assigned:
Status: Not a bug Package: *Compile Issues
PHP Version: 5.3.9 OS: Fedora 16
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: czachary at wiley dot com
New email:
PHP Version: OS:

 

 [2012-01-12 15:31 UTC] czachary at wiley dot com
Description:
------------
I am receiving the following compile issue when trying to compile the mysql.so in the ext/mysql folder using mysqlnd.  Please see the detail below.

./configure --prefix=PATH --with-php-config=/x/y/z/bin/php-config --with-mysql=mysqlnd --with-zlib-dir=/usr

Error:

php-5.3.9/ext/mysql/php_mysql_structs.h:39:33: fatal error: ext/mysqlnd/mysqlnd.h: No such file or directory
compilation terminated.
make: *** [php_mysql.lo] Error 1


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-01-28 00:21 UTC] rasmus@php.net
-Status: Open +Status: Not a bug
 [2012-01-28 00:21 UTC] rasmus@php.net
The easiest way to build mysql.so quickly is to cd into the ext/mysql directory 
and run phpize. Then run your configure command from in there. I just tested it 
with the 5.3.9 tarball and it worked fine.

You can also to it from the top-level while you are building all of PHP by 
specifying --with-mysql=shared,mysqlnd
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Feb 25 05:01:25 2020 UTC