php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #60676 Add ability to specify default proxy server for soap extension
Submitted: 2012-01-07 02:19 UTC Modified: 2015-04-06 20:52 UTC
Votes:6
Avg. Score:4.3 ± 0.5
Reproduced:5 of 5 (100.0%)
Same Version:5 (100.0%)
Same OS:3 (60.0%)
From: samm at os2 dot kiev dot ua Assigned: dmitry (profile)
Status: Wont fix Package: SOAP related
PHP Version: 5.3.8 OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: samm at os2 dot kiev dot ua
New email:
PHP Version: OS:

 

 [2012-01-07 02:19 UTC] samm at os2 dot kiev dot ua
Description:
------------
I found that there is no way to change default SoapClient settings. I have a project installed in proxy environment and i want to avoid major code changes. 
Proposed changes will add 3 ini variables:

1) soap.proxy_host 
2) soap.proxy_port
3) soap.proxy_login
4) soap.proxy_password

If this settings are specified in ini (or using ini_set()) then SoapClient will use them by default. It is still possible to override them in the object parameters array. 

Test script:
---------------
Any SoapClient call without parameters in the proxy-only network.

Expected result:
----------------
After this patch and setting ini variables proxy will be used.

This is example from my test machine:

ini_set("soap.wsdl_cache_enabled", "0");
ini_set("soap.proxy_port", 3128);
ini_set("soap.proxy_host", "127.0.0.1");
//ini_set("soap.proxy_login", "test");
//ini_set("soap.proxy_password", "test");



Patches

php-soap-proxy-patch (last revision 2012-01-07 02:20 UTC) by samm at os2 dot kiev dot ua)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-01-10 06:58 UTC] dmitry@php.net
-Assigned To: +Assigned To: dmitry
 [2013-03-10 03:24 UTC] Danack at basereality dot com
Possibly duplicate of https://bugs.php.net/bug.php?id=29280 which would set proxy 
settings for all connections.

However that bug says that it's fixed, however there appears to be no 
documentation of how to use the 'new' ini file settings.
 [2013-03-10 06:34 UTC] samm at os2 dot kiev dot ua
I don`t see any reference that this bug is fixed, and i think it is not. I can provide documentation for new ini settings if you need it. Bug you mentioned is the same but contains no real solution.
 [2013-03-11 10:12 UTC] dmitry@php.net
This feature request wasn't implemented.
Few years ago it was decided not add new php.ini directives without a serious need. I agree that such options might be helpful, but it's much better to support them at application level.
 [2013-03-11 10:49 UTC] samm at os2 dot kiev dot ua
Thank you for reply, I don`t think that adding such variables will cause  any problems. Internet access via proxy is not a common case and most of SOAP applications are not supporting it on a code level. This patch allows to use such apps with proxy transparently, without any code changes. But if you are not going to implement this I think its a good time to close the ticket.
 [2015-04-06 20:52 UTC] dmitry@php.net
-Status: Assigned +Status: Wont fix
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC