php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #60642 Missing constant PHP_QUERY_RFC1738 and PHP_QUERY_RFC3986
Submitted: 2012-01-03 12:50 UTC Modified: 2012-01-03 17:36 UTC
From: michiel at thalent dot nl Assigned:
Status: Not a bug Package: URL related
PHP Version: 5.3.8 OS: Windows and Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: michiel at thalent dot nl
New email:
PHP Version: OS:

 

 [2012-01-03 12:50 UTC] michiel at thalent dot nl
Description:
------------
I'm missing the contansts PHP_QUERY_RFC1738 and PHP_QUERY_RFC3986.
I believe their value should be resp 1 and 2.


Test script:
---------------
<?php
echo PHP_QUERY_RFC1738 . "\n";// will throw a notice
echo PHP_QUERY_RFC3986;// will throw a notice
?>

Expected result:
----------------
1
2

Actual result:
--------------
You will get a notice error.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-01-03 17:36 UTC] mgdm@php.net
-Status: Open +Status: Bogus
 [2012-01-03 17:36 UTC] mgdm@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately you are not using a current version of PHP -- 
the problem might already be fixed. Please download a new
PHP version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.

Those constants were added along with the enc_type parameter in PHP 5.4.0 - check 
the changelog on http://php.net/http_build_query.
 [2012-01-03 18:01 UTC] michiel at thalent dot nl
Well the documentation says:

The following constants are meant to be used with parse_url() and are available since PHP 5.1.2. 
(...)
PHP_QUERY_RFC1738 (integer)
PHP_QUERY_RFC3986 (integer) 

And i'm not sure how long the doc already is saying that.
I noticed this problem when using a library that was last updated January 2011. So those constants must have been know by then already.
But when its in php5.4 right now, I think only the documentation should be changed then.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Jan 25 02:03:35 2022 UTC